none
[UWP]Defaut keyboard instead of NumericPin keyboard shown to PaswordBox first time after machine is rebooted RRS feed

  • Question

  • Hi,

    I have a UWP APP (with SDK 17763), contains PasswordBox which been installed to windows OS 1809 machine, has touchable screen. in settings->device->Typing->Touch keyboard,  I toggled on "Show the touch keyboard when not in tablet mode and others no keyboard attached"

    My app shows default keyboard every first time after it installed or after machine is rebooted. second time or later opening

    will show the number keyboard.

    Can anybody explain to me, why this happening. 

    BR.

    Lishan


    Thursday, February 7, 2019 10:11 AM

All replies

  • Hi,

    Well currently I don't have such a touch device (Build 1809) here. I need some time to find a device to test here. 

    I have some other question before make a test about this. Is it just simple PasswordBox that enough to reproduce the issue? Do you have any code snippet about this? It would be better if you could off a code snippet here.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, February 8, 2019 4:23 AM
    Moderator
  • Hi Roy,

    It is just a simple PasswordBox in UWP, as shown below the MainPage.xml

    <Page
        x:Class="passwordbox.MainPage"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:local="using:passwordbox"
        xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
        xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
        mc:Ignorable="d"
        Background="{ThemeResource ApplicationPageBackgroundThemeBrush}">

        <Grid>
            <PasswordBox InputScope="NumericPin"></PasswordBox>
        </Grid>
    </Page>

    I found out that virtual keyboard works differently in Win OS 1809. after I right click the Taskbar, then select "show touch keyboard button". the problem disappeared. I have no idea why it works if I show the touch keyboard button in Taskbar.

    BR.

    Lishan

    Monday, February 11, 2019 10:24 AM
  • Hi,

    I asked other engineers to test about this issue in touch screen but not in Surface. We could not reproduce your issue. Have you tried this on other devices? Do you get the same behavior?

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, February 12, 2019 8:06 AM
    Moderator
  • Hi Roy, 

    I tried on other devices, the same issue. When you try to reproduce that, make sure there is no keyboard icon shown on taskbar. the icon is enabled/disabled by right click TaskBar, then select ""Show touch keyboard button""

    BR.

    Lishan


    Monday, February 18, 2019 9:35 AM
  • Hi Roy,

    If you just start the APP, click on the input pane, number keyboard show, then close the APP by pressing cross icon on upper right corner, you will see the number keyboard closed first, then the character keyboard show as a flicking before APP closed.

    BR.

    Lishan

    Monday, February 18, 2019 8:10 PM
  • Hi,

    I managed to find a surface in build 1809 to test. But I'm sorry to say that I could not reproduce this issue as well. I run the sample on the surface. And as you mentioned, I disabled "Show touch keyboard button" of the taskbar. When the app is launched, I tapped the input panel, the keyboard is shown and it's a number keyboard. I didn't get the behavior that shows a character keyboard when it's first shown.

    But I did find that the character will show after the app is closed. And it will automatically closed soon after the app is closed.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 20, 2019 7:06 AM
    Moderator
  • Hi Roy,

    My device is Lenovo X1 Carbon, Winver 1809 OS Build 17763.316. Do you think this is a bug that the character keyboard is shown (flicking) after app is closed?

    BR.

    Lishan

    Wednesday, February 20, 2019 7:43 AM
  • Hi,

    There is still one thing needs to be confirmed. Does this behavior (character keyboard will show after the app is closed) happen on previous build? Have you test about this? I just want to know if this also happens on other version of windows 10.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, February 22, 2019 9:50 AM
    Moderator
  • Hi Roy,

    I haven't test it on older version, all my devices are updated to 1809.

    Any workaround that I can get rid of it?


    • Edited by lishan.laulu Tuesday, February 26, 2019 12:00 PM
    Tuesday, February 26, 2019 8:33 AM
  • Hi,

    I'm sorry to say that currently there is no way except enable 'Show touch keyboard button'. I just want to know if the problem exists in early versions. If so, this might be a default behavior by some internal mechanisms. If this only happens on the new version, that will be a problem.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 27, 2019 8:25 AM
    Moderator