locked
Navigation Failed (some timeout?) RRS feed

  • General discussion

  • Hi, I'm wrote some app that load lots of data... in first screen I have button to navigate to a second page.
    Second page load all data to a list - it took some time
    In XDE work fine (becouse my computer is faster then phone), on my device (HTC Mozart) in debug time, also work fine (its take 5-10 seconds to load page).
    But when I run app from app list (not pluge-in to VS) application quits like UnhandledException.
    I try put some messageBox in UnhandledException and NavigationFailed event, but no luck. What is going on? Is there any timeout for page load?
    Why application exit in normal use, but while debugging works fine....
    Saturday, June 11, 2011 2:08 PM

All replies

  • Look at the callstack of the exception.  Put some try..catch clauses in there to try to get more information about what is causing it to fail.
    Saturday, June 11, 2011 2:17 PM
  • I have not callstack, cause I can't catch exception. Application simply quits :/
    I used try...catch in NavigationService.Navigate statment, in Loaded event... nothing catch exception... always after 10 seconds I'm back to tiles manu...
    Saturday, June 11, 2011 4:22 PM
  • The systems abort the app if it takes more than 10s to load the first time, but after being running I think that there ins't a timeout.


    Windows Phone gives your application 10 seconds of “real world clock time” (not actual 10 second of CPU time) to load your application. Windows Phone Marketplace certification requirements further limit your application’s allowable load time to about 5 seconds. Therefore, it is important for you to get your load time under control.
    Saturday, June 11, 2011 7:51 PM