The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Developing Universal Windows apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Emulator Issue RRS feed

  • Question

  • Hello,

    I have Visual Studio 2010 Professional installed on my Windows 7 PC.  I have installed the WP7 developer tools and January update.  I have spent about an hour on a new phone app and just hit the "play" debug button to launch the phone emulator.  When pressing the play button however, I get this error message:

    Application launch failed.  Ensure that the device screen is unlocked and device is developer unlocked.  For details on...

    It appears that VS2010 is attempting to load my app on my Windows Phone 7 phone instead of in the emulator.  

    At home I have Visual Studio 2010 Express for Windows Phone install on my PC and I do not experience this issue.

    How do I tell Visual Studio 2010 Professional to load my app in its emulator instead of attempting to load it on my phone?

    Thank you in advance.

    Karl

    Thursday, March 24, 2011 3:24 PM

All replies

  • There is a combobox for emulator/device close to the one where you can select debug/release. ;)
    Thursday, March 24, 2011 3:38 PM
  • FYI: There are two different toolbars for target selection, the one in the "Standard" toolbar is for Silverlight projects...

     

       For Windows Phone Application projects, i.e. using Silverlight framework, you need to use the target selection in the "standard" toolbar.

       -> To show the standard toolbar open the "View" menu and select "Toolbars" then "Standard"

     

       For XNA projects you need to use the "XNA Game Studio Device Management" toolbar. 

       -> To show the XNA toolbar open the "View" menu and select "Toolbars" then "XNA Game Studio Device Management"

    Thanks.

    Thursday, March 24, 2011 4:03 PM
  • Normally, the drop-down should default to the emulator and not the device.  You can use the steps in this blog post to reset the default value if the drop-down on your computer defaults to the device so you don't have to remember to change it each time.

    Thanks!

    Friday, March 25, 2011 4:04 AM
    Moderator
  • Hi Aaron,

    Noticed your tip on 3/24. But re-discovered it today and tried it. It worked. Hope no more issues.
    Friday, April 15, 2011 6:46 PM