跳转至主内容

 none
VS2019 本地运行与调试都正常,但将项目发布到Azure 应用服务时VS直接停止工作 RRS feed

  • 问题

  • 应用程序在本地调试运行都是正常,通过VS2019导入Azure发布配置文件,直接发布到Azure应用服务,到了“启动 Web Deploy 以将应用程序/发布到....” 这一步,VS2019 就会弹出自动停止工作的提示(Microsoft Visual Studio 2019 已停止工作)


    请问有什么方案可以解决问题?

    2019年10月12日 4:18

全部回复

  • Hi LZD_Jay,

    欢迎来到MSDN论坛。

    首先你请先对照此文档查询你是否在网站发布到Azure应用服务中配置出现问题。而且当你在connection里去配置连接azure服务,请注意你的连接是否成功,你可以在表单里点击验证连接去验证连接是否通过。

    > >你也可以尝试清理一下缓存文件,排除对此功能的干扰:

    • 删除以下文件夹文件: C:\Users\xxx(user account)\AppData\Local\Temp 
    • C:\Users\perryq\AppData\Local\Microsoft\Team Foundation

    顺便说一下,你也可以将你的问题重定向到Stack Overflow以便获得更专业的支持。

    希望能帮助到你。

    Best Regards,

    Perry

      


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com




    2019年10月14日 7:50
  • Hi Perry,

    Azure 发布配置服务连接是正常的。

    尝试你提供的方案清理缓存文件,再次打开Visual Studio 2019工具来发布azure应用程序,发现问题还是存在。

    从系统的“事件查看器”检索到日志情况如下:

    ******************************************************************

    错误应用程序名称: devenv.exe,版本: 16.3.29411.108,时间戳: 0x5da0feb7
    错误模块名称: webio.dll,版本: 10.0.18362.1,时间戳: 0xb8c0f960
    异常代码: 0xc0000409
    错误偏移量: 0x0003fb4e
    错误进程 ID: 0x3a98
    错误应用程序启动时间: 0x01d58405456f5756
    错误应用程序路径: C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\devenv.exe
    错误模块路径: C:\WINDOWS\SYSTEM32\webio.dll
    报告 ID: 999f02ca-c9a6-4309-a444-50ad39f163a6
    错误程序包全名: 
    错误程序包相对应用程序 ID: 

    ******************************************************************

    这是系统的问题导致 Visual Studio 2019 工具崩掉?有没有什么好的解决方案?

    Thanks!

    2019年10月16日 9:50
  • Hi LZD_Jay,

    根据你的进一步信息,请尝试还原你的默认vs设置通过在Developer Command Prompt里输入devenv.exe / ResetUserData / ResetSettings

    或者清理当前解决方案物理路径下的 .vs的文件夹,它只要是存在你的项目文件的一些配置信息。做完此步骤然后在重新打开项目加载在试试。

    ##错误模块路径: C:\WINDOWS\SYSTEM32\webio.dll

    >>建议你在cmd中重新注册此DLL

          ------- for %1 in (%windir%\system32\*.dll) do regsvr32.exe /s %1

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    2019年10月16日 11:38
  • Hi Perry,

    试过你提供的方案,对于问题还是没解决,这种情况下是否只有重置系统才能解决问题?

    2019年10月21日 6:15
  • Hi LZD_Jay,

    很抱歉这么晚回复你。

    如果实在不行的话,你可以尝试使用sfc /scannow去检查并修复损坏的系统文件。如果不行的话,如你所述重装系统。

    Best Regards,

    Perry


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    2019年10月22日 9:27