none
O evento de clique do botão dispara ModalPopupExtender mas não desliga RRS feed

  • Pergunta

  • PessoALL,

         O MODAL aparece, mas NÃO quer mais sair mais!
         Como resolvo isto?

         Tenho um código em ASP.Net, .Net Framework 4 com Visual Studio 2010.

    <td style=";">
    
        <asp:button ID="hButton1" runat="server" Style="display:none;"/>
    
        <asp:Button ID="btnUploadArq" runat="server" CssClass="Botao" Text="Carregar Arquivo"
            Style="height: 5em; ; z-index: 99999!important;" ToolTip="Enviar o arquivo selecionado"
            TabIndex="2" OnClick="_btnUploadArq_Click" />
    
        <ajaxToolkit:ModalPopupExtender ID="ModalPopupExtender1" runat="server" TargetControlID="hButton1"
            PopupControlID="updateProgress" BackgroundCssClass="modalBackground">
        </ajaxToolkit:ModalPopupExtender>
    
    </td>

         Preciso colocar uma mensagem de espera de formulário MODAL (ModalPopupExtender1) para o usuário:    

    protected void _btnUploadArq_Click(object sender, EventArgs e)
    {
       ModalPopupExtender1.Show();
    
       if (ArqUpload.HasFile)
           ImportaArq(ArqUpload.PostedFile);
    }

         Segui o exemplo da página:

    ============================================
    ModalPopupExtender OK Button click event not firing:

    https://forums.asp.net/t/1969191.aspx?ModalPopupExtender+OK+Button+click+event+not+firing+
    ============================================
    ModalPopupExtender chamando .Show () não funciona

    https://stackoverflow.com/questions/37541686/modalpopupextender-calling-show-does-not-work
    ============================================

    Obrigado pela ajuda,
    Fabio I.
    quinta-feira, 13 de maio de 2021 11:47

Todas as Respostas

  • Ola Fabio,

    Voce ja tentou algo assim?

    protected void Page_Load(object sender, EventArgs e)
    {
        if (!this.IsPostBack)
        {
            ModalPopupExtender1.Show();
        }
    }

    quinta-feira, 13 de maio de 2021 18:22
    Moderador
  • Mauricio,

       Estou testando agora e a modal não aparece.
       Percebi que no rodapé já tem uma mensagem de, exemplo: "Carregando 10%"... será que está atrapalhando o meu modal?

    []'s,
    Fabio I.

    quinta-feira, 13 de maio de 2021 18:46