スキップしてメイン コンテンツへ

 none
SurfaceProでBLE通信の再接続ができない RRS feed

  • 質問

  • Surface pro5で動作するBLE(GATT)通信アプリケーションを開発しています。

    Surfaceの電源ON後、最初の通信は問題なくできるのですが、
    一度Bluetooth通信を切断すると、Surfaceを再起動するまで再接続できません。
    Surface pro5は2台保有していますがいずれも同じ状況です。
    ただし、Windows10の他のPC(HP製)で動作させると、再起動しなくても
    実行ファイルを再起動すれば再接続できます。

    接続失敗時の理由を調べたところ、serviceの検索後、characteristicsを選択して通信しようとしているのですが、
    検出されるcharacteristicsの数が「0」となり接続失敗していました。

    接続相手は、Microchip社製のRN4870で、
    UART Trans parentモードを起動させています。
     service GUID: 49535343-fe7d-4ae5-8fa9-9fafd205e455
     characteristics GUID:49535343-1e4d-4bd9-ba61-23c647249616
    に接続しようとしています。

    自作のソースでも、BLE通信フリーアプリ(Bluetooth LE lab)を使用しても同じ状態でしたので、
    Surface特有の問題かと思い、質問させていただきたく次第です。

    Surfaceだと別のBLE処理が必要なのでしょうか。
    何かご存知の方がいらっしゃいましたら教えていただけますと幸いです。


    • 編集済み HoriH 2019年12月13日 0:20
    2019年12月13日 0:17

すべての返信

  • HoriHさん、こんにちは。フォーラムオペレーターのクモです。
    MSDNフォーラムにご投稿くださいましてありがとうございます。

    ご質問によると、これはSurfaceProに関連してると思います。
    より良いサポートのために、TechNetフォーラムにご投稿のほどお願いします。

    どうぞよろしくお願いいたします。 

    MSDN/ TechNet Community Support Kumo ~参考になった投稿には「回答としてマーク」をご設定ください。なかった場合は「回答としてマークされていない」も設定できます。同じ問題で後から参照した方が、情報を見つけやすくなりますので、 ご協力くださいますようお願いいたします。また、MSDNサポートに賛辞や苦情がある場合は、MSDNFSF@microsoft.comまでお気軽にお問い合わせください。~

    2019年12月17日 6:45
    モデレータ
  • クモ様

    お世話になります。
    ご教授いただきありがとうございます。
    この質問は削除させれいただき、そちらに投稿させていただきます。

    よろしくお願いいたします。

    2019年12月17日 8:15
  • HoriHさん、こんにちは。フォーラムオペレーターのクモです。
    ご返信いただきありがとうございます。

    お手数ですが、ご削除のほどどうかよろしくお願いいたします。

    引き続きMSDNフォーラムをご利用いただけますようお願い申し上げます。

    MSDN/ TechNet Community Support Kumo ~参考になった投稿には「回答としてマーク」をご設定ください。なかった場合は「回答としてマークされていない」も設定できます。同じ問題で後から参照した方が、情報を見つけやすくなりますので、 ご協力くださいますようお願いいたします。また、MSDNサポートに賛辞や苦情がある場合は、MSDNFSF@microsoft.comまでお気軽にお問い合わせください。~


    2019年12月18日 1:23
    モデレータ