Saltar al contenido principal

 none
visual studio 2017 c# se quedo como congelado en un cierto punto y desde ai se inicia, no puedo modificar y agregar nada RRS feed

  • Pregunta

  • Buenas y un saludo para todos espero que me puedan ayudar con mi aplicación que estoy creando en c#

    mi problema es el siguiente:

    estoy creando un systema de punto de venta en c# todo funciona bien puedo registrar modificar eliminar desde todos los formularios que tengo en mi aplicación;

    el problema es que mi aplicación se quedo en un punto en el cual desde ai se inicia, en el modo diseño de visual estudio yo puedo agregar cualquier control puedo agregarle códigos puedo hacer todo normal,

    la cosa es que mi aplicación se inicia siempre desde el punto donde se quedo congelado, y desde ai no importa lo que haga no me hace nada ni siquiera me depura los posibles errores que tuviera, incluso e probado borrando controles asta la borre el formulario donde me paso eso, pero igual mi aplicación se inicia y sigue trabajando de lo mas normal asta me aperasen los colesteroles que borre incluso se inicia si el formulario esta borrado igual aperase,

    espero que me aya echo entender y me puedan ayudar por favor.

    se los paso el código que estaba probando cuando me paso esto

    int minuto = 15;

    DateTime Hora = DateTime.Now;

    MessageBox.Show(Hora.AddMinutes(-Hora).ToLongTimeString());

    ese código lo asocie al un Button y desde ai espeso todo

    viernes, 22 de noviembre de 2019 4:45

Respuestas

  • Hola   Edua9920

     

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma,  te  sugiero realizar lo siguiente:

     

    1.  Necesitamos que nos compartas (si es el caso) que mensaje de error te muestra cuando se "congela".
    2.  ¿Al ejecutar  tuprograma, este te muestra una excepción? 

     

     

    Gracias por usar los foros de MSDN.

     

    Pablo Rubio

     

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:16
    viernes, 22 de noviembre de 2019 22:16
    Moderador
  • hola

    >>igual mi aplicación se inicia y sigue trabajando de lo mas normal asta me aperasen los colesteroles que borre

    tienes que forzar la compilacion

    no uses el F5 o el play porque no va a funcionar, tienes que hacer un ReBuild de la solucion

    Tambien podrias ir a la carpeta donde esta el proyecto y eliminar el contendido de la carpeta \bin que es donde compila el VS, de esta forma lo fuerzas a recompilar

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:14
    • Desmarcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:14
    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:18
    • Desmarcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:18
    • Marcado como respuesta Edua9920 domingo, 24 de noviembre de 2019 4:37
    sábado, 23 de noviembre de 2019 4:59

Todas las respuestas

  • Hola   Edua9920

     

    Gracias por levantar tu consulta en los foros de MSDN. Con respecto a la misma,  te  sugiero realizar lo siguiente:

     

    1.  Necesitamos que nos compartas (si es el caso) que mensaje de error te muestra cuando se "congela".
    2.  ¿Al ejecutar  tuprograma, este te muestra una excepción? 

     

     

    Gracias por usar los foros de MSDN.

     

    Pablo Rubio

     

     ____

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:16
    viernes, 22 de noviembre de 2019 22:16
    Moderador
  • buenas:

    ese es el detalle que no me salta ningún error:

    e provocado errores a propósito y nada, igual se inicia como si estuviera bien todo 

    e colocado puntos de interrupción y nada igual se inicia, es como si se aya quedado vinculado a una cierta parte de mi aplicación y desde ai se inicia, por ejemplo tengo un formulario llamado Egreso, ya casi lo tenia listo, lo borrare porq fue ai donde me comenzó todo, pero igual mi aplicación se inicia y me muestra el formulario Egreso que ya lo borre, y sigue trabajando de lo mas normal con el.

    sábado, 23 de noviembre de 2019 3:52
  • hola

    >>igual mi aplicación se inicia y sigue trabajando de lo mas normal asta me aperasen los colesteroles que borre

    tienes que forzar la compilacion

    no uses el F5 o el play porque no va a funcionar, tienes que hacer un ReBuild de la solucion

    Tambien podrias ir a la carpeta donde esta el proyecto y eliminar el contendido de la carpeta \bin que es donde compila el VS, de esta forma lo fuerzas a recompilar

    saludos


    Leandro Tuttini

    Blog
    MVP Profile
    Buenos Aires
    Argentina

    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:14
    • Desmarcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:14
    • Marcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:18
    • Desmarcado como respuesta Edua9920 sábado, 23 de noviembre de 2019 11:18
    • Marcado como respuesta Edua9920 domingo, 24 de noviembre de 2019 4:37
    sábado, 23 de noviembre de 2019 4:59
  • Buenas y poden por marcar y desmarcar como respuesta:

    primera ves que utilizo en sitio y no se si lo estoy asiendo bien perdón y disculpas

    si probé asiendo un ReBuild de la solución y no me dio resultado

    lo que no ice fue eliminar el contendido de la carpeta bin, pero ya avía tomado la decisión de de volver mi PC unos días atrás ante de tu msm y con eso resolví el problema.

    Ahora si ya tengo un error:

    antes de que me sucediera todo esto yo hacia referencia a una clase de SdlTableDependency y todo me funcionaba todo bien estaba perfecto:

    el error que tengo es que no me aperase la referencia de SdlTableDependency pero si esta instalado.

    lo e desinstalado y lo e vuelto a instalar y nada no me aparece la referencia el paquete lo instale desde NuGet

    si me echan una manito con eso se los agradecería 

    y una orientación de uso de la aplicación muchísimas gracias 

    sábado, 23 de noviembre de 2019 11:42