none
How to increase an IIS webservice time-out period in Windows 10? RRS feed

  • Question

  • In an IIS (version 10.0) webserivce under Windows 10, you know, the default time-out period is 110 seconds. I was trying to extend the time-out duration to 200 seconds (3 minutes 20 seconds).

    I got a hyperlink https://stackoverflow.com/questions/2414441/how-to-increase-request-timeout-in-iis/51010915 for a solution to increase the IIS webservice time-out duration, on my Win10 Laptop, but all of the approached failed to make even a second extension!

    In summary, I have applied the following approaches:

    1) Set the "executionTimeout" value to be 200 seconds in the web.config file and a specific .aspx page file in a webservice application. For example,

    <system.web>
        <httpRuntime executionTimeout="200" />
    </system.web>

    2) adjust the server webFarm configuration in the Win10 configuration file %WinDir%\System32\Inetsrv\Config\applicationHost.config

    For example,

    <webFarm name="${SERVER_NAME}" enabled="true"> 
      <server address="${SERVER_ADDRESS}" enabled="true">
        <applicationRequestRouting httpPort="${SERVER_PORT}" />
      </server>
      <applicationRequestRouting>
        <protocol timeout="${TIME}" />
      </applicationRequestRouting>
    </webFarm>

    3) set the "connection time out" value in IIS "Advance Settings". The detailed operations are shown below:

    1. Open your IIS
    2. Go to "Sites" option.
    3. Mouse right click.
    4. Then open property "Manage Web Site".
    5. Then click on "Advance Settings".
    6. Expand section "Connection Limits", here you can set your "connection time out"


    4) Run the following Power Shell command:

    Set-WebConfigurationProperty -pspath 'MACHINE/WEBROOT/APPHOST/Default Web Site'  -filter "system.web/httpRuntime" -name "executionTimeout" -value "00:03:20"

    5) Execute the following AppCmd commands:

    appcmd.exe set config "Default Web Site" -section:system.web/httpRuntime /executionTimeout:"00:03:20"

    Now I am seeking for your help to provide a workable solution. 

    Thanks!

     

    Wednesday, September 11, 2019 4:34 PM