none
FolderBrowserDialog does not show network drives on Windows 8 RRS feed

  • Question

  • Hi,

    On Windows 8 when we use FolderBrowserDialog, the network drives are not displayed. It works fine if we run the same program on Windows 7. Do you know if it's a Windows 8 restriction?

    Thanks.

    Olivier

    Monday, October 8, 2012 3:28 PM

Answers

All replies

  • Hi Olivier,

    I don't think so.

    Here is a screenshot of windows 8.

    Does it contains any network drive? Can you access them?

    Best Regards,


    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, October 10, 2012 8:11 AM
  • Hi,

    Thank you for the answer, we have reproduce the issue on 2 different Windows 8 64-bit machines. In the screenshot you can see that Z: network drive isn't displayed in FolderBrowseDialog. I run this program with an administrator account and elevated privileges. This account has previously created the Z: network drive. The dialog is created with no specific options:

    FolderBrowserDialog dialog = new FolderBrowserDialog();
    dialog.Description = this.labelFolder.Text;

    if (dialog.ShowDialog() == DialogResult.OK)
    {
    this.textBoxDownloadFolder.Text = dialog.SelectedPath;
    }

    

    Regards.

    Olivier

    Thursday, October 11, 2012 6:43 AM
  • Hi Olivier,

    I'm still not sure what is going on. I will invoke other engineer in this issue.

    Best Regards,


    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us

    Friday, October 12, 2012 7:43 AM
  • Hello Olivier,

    I also cannot repro the issue and I cannot find any related bug report in our internal database.   Could you please provide us with more information?  Are you using VS 2012 or VS 2010?  What's the target .NET Framework version are you using? 

    Besides, please make sure you have installed the latest update of Windows 8.

    Good day!

    Thanks


    Michael Sun [MSFT]
    MSDN Community Support | Feedback to us

    Friday, October 12, 2012 8:13 AM
    Moderator
  • Hi,

    Ok, i know how to reproduce:

    - Create a Visual 2010 WinForms project targetting .NET 4

    - Remove the "Application.Run(form);" line and replace it by: "new FolderBrowserDialog.ShowDialog();"

    - Add a manifest file specifying to run with elevated privileges:

      <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
        <security>
          <requestedPrivileges>
            <requestedExecutionLevel level="requireAdministrator" uiAccess="false"/>
          </requestedPrivileges>
        </security>
      </trustInfo>

    1. If you run this program on Windows 8 Entreprise 64-bit, the network drives are not displayed.

    2. If you remove the <trustinfo> from the manifest file, then the network drives are displayed.

    On Windows 7 there's no problem, it always works, this bug is specific to Windows 8. I have tried to apply the latest available updates for Windows 8, it has no effect.

    Olivier

    Friday, October 12, 2012 9:21 AM
  • Hi Olivier,

    Thanks for providing us with the repro steps.  Based on your description, I can repro it and even in VS2012 I can also repro this strange issue.  I would recommend you open a bug ticket in Microsoft Connect to report it the product team. 

    https://connect.microsoft.com/visualstudio

    Good day!

    Thanks


    Michael Sun [MSFT]
    MSDN Community Support | Feedback to us

    Monday, October 15, 2012 2:08 AM
    Moderator
  • Monday, October 15, 2012 10:03 AM
  • I have discovered a problem and the solution. It is in the naming conventions i.e.  there must not be ()._*$# in the name it should be in CAPS but not upper and lower case. I renamed my two firebird drives on the LAN and it now works fine. The renaming is not in the mapping but the actual drive or storage media itself. It is strange that it worked through XP, Vista and windows 7 perfectly using (A) but 8 does not like it. So a simple renaming seems to be the trick - remember the drive must be renamed as opposed to mapping. That was six hours work to find why it would not work. Now is perfect-perfect and fast.
    Friday, October 26, 2012 10:15 PM
  • Yea i know..

    It happens when you use programs that run in "run as administrator" mode - Elevated Programs or Installers
    maybe microsoft missed somthing that will fixed later by windows update ? i realy dont know or care cuz i can fix it. 

    you can fix it your self by forcing windows to make the network drives available to standart and administrator acounts:

    1 - run regedit
    2. - locate HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System
    3 - create a new DWORD entry with the name EnableLinkedConnections and value 1.
    4 - restart your computer
    5 - now you can see and use network drives with these installers or applications.

    :)

    jobab

    • Proposed as answer by Rene_13 Friday, May 31, 2013 9:53 PM
    Wednesday, November 14, 2012 8:45 PM
  • Jobab

    Thank you! This worked perfectly! I had been meaning to create an account to submit replies, but thanks to you I managed to get two birds with one stone!

    I used this to fix an issue for Outlook 2010 on Windows 8 x64 bit. The system had mapped network drives connected, but within outlook 2010 it would "drop" the network drives. Your registry edit fixed this.

    Thank you

    -Rene

    Friday, May 31, 2013 4:53 PM
  • I am also facing same problem. But creating new registry is not helping me. Is there any other things to do?
    Saturday, August 24, 2013 5:36 AM
  • Thanks for this! (years later)
    Sunday, April 26, 2015 2:55 AM
  • Thanks a lot! This works on Windows 10 also
    Wednesday, November 18, 2015 12:54 PM
  • I ran visual studio 2015 as non admin and I was able to see the network drives :-)

    Codernater

    Monday, August 1, 2016 7:46 PM
  • This worked like a charm for me. On Windows Server 2012, my network drives were not populating within Microsoft Deployment Toolkit>New application>Browse. Did this and rebooted, and they were there. Thanks!!!!!!!!!!
    • Edited by KennyluvsMDT Wednesday, February 1, 2017 11:40 PM
    Wednesday, February 1, 2017 11:40 PM
  • Hi can you teach me how did you able to show ma network drives? i cant do it im using vb6
    Wednesday, May 10, 2017 11:04 AM