locked
BUG? - Installing .NET Framework 1.1 - Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll" failed RRS feed

  • General discussion

  • I had to install an application that required the .NET 1.1 Framework (Smarterstats 3.3) for a client. This application automatically installs .NET Framework 1.1. After the installation completed I began to get the following error on all .aspx sites:

     

    Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll" failed

     

    Furthermore, I could not load any handler mappings modules in IIS for the same .aspx sites. I would get the following error. 

     

    There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined in web.config (C:\WebsitePanel\Portal)

    When I deleted the duplicate sections in the websitepanel portal web.config I was able to get into the handler mappings in IIS. I found that all the .NET 4.0 handler mappings had been completely replaced by .NET 1.1 handler mappings. 

    The fix was to completely uninstall .NET 4.0 and reinstall it. 

     

     

    Wednesday, September 8, 2010 5:16 PM

All replies

  • By the way. This was a Windows 2008 server, IIS7, .NET was originally installed using the Web Platform Installer.

     

    Wednesday, September 8, 2010 5:17 PM
  • We had the very same symptoms after we had to install .NET Framework 1.1 in order to use the MSSCCI API in SourceGear Vault.   Thank you for posting.  I will reinstall .NET 4.0.     The install process did warn of a potential 'incompatibility'.     .NET hell has replaced .dll hell.

     


    Order Processing Technologies
    Tuesday, February 22, 2011 8:55 PM
  • all u need to do is

    Get a command prompt in administrator mode and go to C:\Windows\Microsoft .NET\FrameWork64\v4.xxx

    and run aspnet_regiis -r.  This will re-register the right libraries.  It has happened twice already to me.

    For other frameworks (32 bit or other versions of .net make sure you go to the correct folder (i.e. Framework/v2.xxx, etc.)

     

    best regards


    Joe
    Sunday, July 31, 2011 10:54 AM
  • Please note, this will set all appPools to use .NET V4.0.
    Thursday, August 25, 2011 7:59 PM
  • Please note, this will set all appPools to use .NET V4.0.


    sure no, if you want to change the app pool's framwork go the pool and then on adavance option or properties you can change the framwork,

     

    regards


    Joe
    Friday, August 26, 2011 5:14 PM
  • I tried this, still didn't work for me. Any other solutions?
    Monday, December 5, 2011 6:10 AM
  • aspnet_regiis -r dit not work for me either.

    Running aspnet_regiis -u (uninstall) and then aspnet_regiis -i (install) worked fine.

    Wednesday, January 25, 2012 9:11 AM
  • I had the same issue. 

    Calling LoadLibraryEx on ISAPI filter "C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_filter.dll" failed

    aspnet_regiis -r dit not work for me either.

    Running aspnet_regiis -u (uninstall) and then aspnet_regiis -i(install) worked fine.

    That works as mark prins says.

    Thanks a lot.

    Tuesday, April 17, 2012 8:38 PM
  • Thank you Mark!
    Wednesday, October 31, 2012 4:22 PM
  • Be aware that installing the dot.net framework 1.1 on Windows 2007/2008 (even though it is not supported, it is sometimes necessary) introduces a bug that causes this error on ASP.NET 4.0 web sites. To fix it, go to IIS admin, select your server name, then ISAPI filters. Open (double click) ASP.NET_4.0.30319.0 and remove the extra backslash between v4.0.30319 and aspnet_filter.dll. Restart IIS. That should fix the issue.

    Thanks.

    Friday, February 21, 2014 1:41 PM
  • Thank you.  You saved me a ton of time in troubleshooting.

    Monday, December 22, 2014 11:31 PM
  • THANK YOU!!!!
    Tuesday, March 3, 2020 6:03 PM