locked
Windows Phone Bing Maps - No Results RRS feed

  • Question

  • When I first got this phone, I could select an address in my calendar and it would find the location, no problem. Then Nokia ran an update and from then on, when selecting an address, it opens what I assume is Bing Maps (the one I can't uninstall) and says "No Results Found". If I then copy that address and paste it in Here Maps or Drive+ it finds the place perfectly. I then upgraded to 8.1, hoping it would be fixed but it is not. Any ideas?
    Sunday, May 25, 2014 4:11 AM

All replies

  • Hello Krolik314:

    Thank you for posting to the forum regarding the issue you are having with Bing Maps.  You mentioned that this started after installing a update from Nokia.  That would mean the firmware was updated and then this feature stopped working. 

    That sounds like something in the firmware update has caused a disconnect via your calendar and Bing maps.  I have a couple things for you to try before this might require another firmware update from Nokia.

    • Soft reset the phone by going to settings > storage sense > phone > temporary files > delete > Internet Explorer settings > delete history.  Once you are done with that, press and hold the down volume button plus the power button until the phone vibrates and reboots.  Try accessing this address one more time from your calendar.
    • Try launching Bing maps and doing a search for an address in your calendar.  If that address is found, please close maps and then launch your calendar.  See if the address is found after you do this.
    • Finally, try reviewing the address in your calendar and see if editing the address helps.  Try removing the city and state if included, try adding the city and state if not included, try including commas or removing commas.  I would also suggest you try creating a test entry on your calendar of a public place and see if this works.

    Please let us know if you have any other questions or concerns.

    Mark W.


    Friday, May 30, 2014 3:12 AM
    Moderator
  • I have been messing around with it. I soft reset my phone as you asked but it didn't change anything. I have launched the maps app by itself and searched for a location but it still will not find an address. 

    However, I did notice that it can find anything as long as there is no number. For example "123 joe st, town state" it can't find anything unless I remove the 123. Any ideas? Thank you for the help.

    Edit: Well I take that back, I just tried another address that doesn't work (Not from calendar) and I removed the numbers but it still can't find it. 

    Krolik314


    (I have no idea why that second part decided to change font size on me...sorry)
    • Edited by Krolik314 Friday, May 30, 2014 10:42 PM
    Friday, May 30, 2014 10:40 PM
  • I'm getting the same problem on my HTC. Really aggravating. I can't figure out how to get to an address at all. Any address I click on gives me the "No Results" page. 

    Not sure if this is from an update or not... I try to keep things updated as much as possible.

    Monday, June 2, 2014 11:02 PM
  • I have the same problem with MAPS on my wife's Samsung ATIV S with WP 8.1. Anything I search for I get "No result found". My wife told me that it worked last week. Everything is fine on my Nokia 1020.

    Any ideas on how to fix this?

    Tuesday, June 3, 2014 4:50 PM
  • I have been having the same problem with my HTC 8X since installing the 8.1 developer preview.  Address searches in Bing Maps come back with no results found.  I've tried deleting and reloading the map, with no success.  If I cut and paste the address into Here Drive, it works
    Wednesday, June 4, 2014 1:01 AM
  • Hello All:

    Thank you for posting your experience and making us aware of this.  I have been trying to reproduce this behavior and have had no luck.  Especially when I use the maps app outside of my calendar.  At this point I want to mostly gather information from those having this issue.  Additionally, I would like to encourage others with the issue to post here and vote for this thread.

    • Make and model of phone.
    • Current OS version.
    • Current firmware revision.
    • Regional setting of the phone.
    • Country you are located in.
    • Area you are searching for, please provide city and state details, we do not need exact addresses.  If anyone is having this issue with an address that is a public place, do provide the full address so I can be sure I am doing the best I can to reproduce the issue.

    The final thing I might suggest at this point is to have you go into Bing Maps and do a simple search of the city/state your address is in.  Once that state or city loads, do another search for the full address.  Let us know if you have any better success when searching out this address directly from the app or via your calendar after the city/state map has loaded.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Thursday, June 5, 2014 11:47 PM
    Moderator
    • Nokia Lumia Icon (929)
    • OS Version: 8.10.12393.890
    • Firmware: 1028.3566.1417.0047
    • Region: United States
    • Located in United States
    • Searching for Rockford, IL

    I have tried searching Rockford, IL and Maps will find that with no problem so then I tried searching for a Taco Bell, 2602 Auburn Rd Rockford, IL and it said "No Results Found". I believe it worked great before Nokia did an update, before I was 8.1 as well. However, it stopped working before I got 8.1. I actually got 8.1 hoping it would fix it but it did not.


    • Edited by Krolik314 Tuesday, June 10, 2014 1:56 AM
    Tuesday, June 10, 2014 1:52 AM
  • Hello All:

    Thank you for the feedback.  I am at a bit of a loss here as this is something that does not seem to be only present on Nokia phones and I cannot reproduce the issue on any of the three phones I have that run the 8.1 developer preview. 

    I recently tried this with the example provided by Krolik314 and although this address in Rockford did not appear in the drop down, when I searched it out and zoomed in, the map informed me this is a Taco Bell.  I tried this with location services ON and OFF.  I tried this with downloaded maps and with maps I did not download to the phone.  I did do all of my testing via WiFi and did not try over cellular data.  If you have not tried over multiple network connections, can you please try that now.

    Anyone else that is having this issue please post the requested details here and include a comment regarding when you first noticed this, after the 8.1 preview was installed or before.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Friday, June 13, 2014 1:00 AM
    Moderator
  • I have tried searching for any address over cellular data as well as wifi hot spots. Neither are able to locate any address. It does show the map and I can manually search for the location but if I try to tap search and find the location from there it just gives me "no results". I hope this helped.
    Friday, June 13, 2014 4:34 PM
  • Hello Krolik314 and others:

    At this point I do not have any other ideas or suggestions regarding what is leading to your issues with Bing Maps.  As mentioned I have not had any success reproducing this on three different phones so I do not believe this is a OS bug.  It seems most likely that this is related to the OS and the firmware not playing nice together. 

    At this point my suggestions are as follows.

    • Wait for the official release of the 8.1 update that would include firmware updates.
    • Contact your phone manufacturer in regards to updating or reinstalling the firmware currently running on your phone.

    Please let us know if you have any other questions or concerns.

    Mark W.


    Sunday, June 15, 2014 9:29 PM
    Moderator
  • Hi I have the HTC 8x and have this same issue. When I search (almost) any address in maps my phone can't find the address no matter what I do. I've only noticed this happening recently. I've had the phone over a year now and I've never had this problem. (note: I have NOT updated to 8.1)

    One thing I did notice that might help... if I search for an address by forcing the maps app to use the downloaded maps only (did this by putting the phone in to airplane mode) it finds the address right away without any problems.

    Please fix this is very annoying, I use maps all the time. Also I read somewhere that if I take the sim card out and put tape on the back then reinsert it it will fix the issue... it doesn't!

    Thursday, June 19, 2014 11:02 AM
  • My wifes phone is also having the same issue.  We have identical phones, nokia lumia 810s.  Upgraded them both to the wp 8.1 developer preview at the same time.  I have had no issues with my phone but my wifes phone always gives no results found on any address she clicks on or types into bing maps.  I have gone through and all of her settings are identical to mine.  she can text forward an address to me that doesn't work on her phone but it works without issues on mine.

    Friday, June 20, 2014 4:26 AM
  • Hello All:

    Thank you for the continued follow up.  These latest examples further indicate this is an issue that is effecting individual phones and is not looking to be a greater issue with the OS.

    For azsheepdog, can you compare the firmware revisions on each of the two phones you have?  I would be interested to know if they differ.  If not, the only other thing I can suggest at this time is for any Nokia users to consider working with the Nokia care suite to reinstall the previous OS and firmware and then try reinstalling the developer preview to the phone.  Maybe something went wrong with the original install on these phone's that are having this search issue.

    Please let us know if you have any other questions or concerns.

    Mark W.

    Friday, June 20, 2014 6:12 AM
    Moderator
  • Doesn't it seem more likely to be an issue either with the cellular network or MS servers? Like I said if you turn on airplane mode and use your downloaded maps it works fine. So it's almost like map requests are being blocked over cellular network and WiFi.
    Friday, June 20, 2014 9:01 AM
  • Both phones have identical OS and firmware

    OS 8.10.12397.895

    Firmware revision number : 3043.0000.1326.0017

    Hardware revision number 1.0.0.0

    radio software version 2.0.092064.3

    edit:

    also as listed below, if I put her phone in airplane mode it pulls the address from the phone offline maps.

    • Edited by azsheepdog Friday, June 20, 2014 6:55 PM
    Friday, June 20, 2014 6:46 PM
  • Hey yeah that works.  Gives message your network is off, pulling results from your phone(paraphrased I cant get the message to duplicate.)  If I turn off airplane mode, the no results error comes back.
    Friday, June 20, 2014 6:52 PM
  • Yep, turning on Airplane mode works great for me, it finds the results instantly. It's clearly a problem with the servers it has to search to find the location. 
    Wednesday, June 25, 2014 2:02 PM
  • I have the same problem.

    Nokia Lumia 1020 (909)

    OS Version: 8.10.12397.895

    Firmware Version: 3051.40000.1346.0001

    Region: United States

    Located in the United States

    Searching: All searches in the built-in maps app (i.e. not the HERE Maps). 

    Searching works if I turn on airplane mode.


    Thursday, July 3, 2014 4:38 PM
  • I am having the same problem on my Nokia 1520. Changing the Airplane mode returns the proper address, turning it back to normal mode returns "No results found"  We couldn't find any matches for your search. Try a different spelling or search term.  Here Maps or Drive+ finds the address normally when it is typed in.

    OS 8.10.12397.895

    Thursday, July 10, 2014 2:53 PM
  • I have been having this problem for months. So frustrating! One of the great things about WP was the terrific Maps integration, which is now useless. I end up having to use Navigon or Nokia's Maps for every search. But since there is no way to change the default mapping application, one-click address searching from the calendar is totally broken.

    Here are the requested details:

    -          Make and model of phone. HTC 8X

    -          Current OS version. 8.0.10327.77

    -          Current firmware revision. 3030.0.34101.531

    -          Hardware revision number. 0003

    -          Radio software version. 1.17b.32.19.14_15.62b.32.19

    -          Radio hardware version. 3.36.0.D4

    -          Carrier. T-Mobile

    -          Regional setting of the phone. English US

    -          Country you are located in. USA

    -          Address searching for. 1950 N. Milwaukee Ave, Chicago IL

    -          Start with simple search of the city/state. I searched for Chicago IL. Maps didn't really find Chicago, but it found a bunch of locations in Chicago that had "Chicago" in the name (Chicago Fire Department, Chicago Bright Smiles, Office Depot Chicago, etc.). Then when I search for the address above, I still get No Results.

    Also, here is another thing I noticed. When I search for the address above I get the "No Results" error. But when I search for the name of the business at that address ("M & W Liquor"), Maps finds it just fine.

    I also tried Yelpy's workaround by searching for the same address in airplane mode, and in that case Maps finds the address right away. Turn airplane mode off again, search fails again whether wifi is on or off. So it seemed like an issue with the cellular network. But then I tried turning on airplane mode and manually re-enabling wifi, and the search STILL FAILED. So it is not related just to the cellular connection, it seems to be related to the presence of any network connection. I also tried toggling Bluetooth, which had no effect.

    Does anyone know if a hard reset on the phone (factory defaults) solves the problem?

    This is a terrible bug that has to be fixed. People with this issue who travel a lot will rapidly head to Android or iOS if this isn't fixed, I imagine.

    • Edited by gurs Tuesday, July 15, 2014 1:27 PM
    Tuesday, July 15, 2014 1:23 PM
  • So I just updated to Windows Phone 8.1 and guess what THE BUG IS STILL PRESENT. This is just inexcusable at this stage. PLEASE FIX THIS ASAP! Don't make me drop Windows Phone altogether, you really can't afford to be losing users.
    Monday, July 21, 2014 10:38 PM
  • I have the same problem. WP 8.1. Please fix, this is a huge usability issue.
    Monday, July 28, 2014 12:04 AM