Cannot prevent concurrent/multiple connection to RDS with fslogix RRS feed

  • Question

  • Hi,

    I have couple RDS 2019 servers behind 3rd party broker configured with fslogix profile container latest version (currently using 2.9.7621.30127. started with version 2.9.7349.30108).

    I'm trying to make sure that a user that was disconnected from a session and by mistake try to access a second RDS will be denied from access (the broker sent the connection not to the disconnected session).

    I have set the following settings (among others):

    Profile type - Normal direct access

    store search database in profile container - disabled (2019 requirement)

    Allow concurrent user sessions - disabled

    Prevent login with temporary profile - enabled

    prevent login with failure - enabled

    Delete local profile when fslogix profile should apply - enabled

    The problem: If a user is logged in to RDS1 and try to login to RDS2 he get the following errors:

    status:0x00000001 message: Cannot load user's profile

    Reason: 0x000000000 message: The container is attached

    Error code 0x00000021 message: The process cannot access the file because another process has locked a portion of the file.

    So far so good but now the problem start.

    On the RDS2 a local profile is created although the user did not manage to login (because of the restrictions - Allow concurrent user sessions - disabled). This local profile cannot be deleted without restarting the windows search service.

    The worse part is that when the user logoff from RDS1 and the VHD lock file is gone the problem remains: the user cannot logon to the RDS2 no matter what I have tried. The only option that work is restarting the cloud cache service which reset the status of the service. This cannot be done on a working multi user RDS server so I was looking for a solution.

    What I have tried:

    1. made sure it is not a permission problem on the profile share: added everyone full control on the user profile folder (for test purpose) - did not solve the problem.

    2. Made sure it is not a specific profile issue: created a new blank profile for the user - did not solve the problem.

    3. Made sure it is not specific RDS issue: check that it behave the same if the user first login to RDS2 and then try to login to RDS1 - it is the same issue.

    After many hours of testing I'll appreciate any ideas how to get over this problem.



    Saturday, December 12, 2020 3:11 PM