locked
[UWP][SDK]IpOverUsbSvc service missing in windows 10 RC (Build 10240) RRS feed

  • Question

  • After updating to the most recent build of Windows 10 I wanted to deploy my windows phone app to a phone - since this was not working and after some research I found out that the "Windows Phone IP over USB transport service" (IpOverUsbSvc) needs to be started.

    Problem is: There is no such a service, when I check the services on my PC. (I checked for "Windows Phone IP over USB" and also for "IpOverUsbSvc")

    This was no problem in the last Windows 10 Build and was working perfectrly unter Windows 8.1 but at the moment I cannot deploy apps to my phones for testing...which is quite bad since I am a WP developer. ;(

    Any ideas, how I can manually install this service?
    Reinstalling Visual Studio 2015, Installing Windows 8.1 SDK and even Windows Phone 8.0 SDK did not solve the problem.
    Removing the USB device driver from Device manager and re-connecting the phone after this did not solve the problem - no such service was shown in the services.

    thanks for your help,
    Hannes

    Thursday, July 16, 2015 1:55 PM

Answers

  • Hi Hannes,

    Can you try a few things for me.

    1. Were you on Windows 10 OS Preview 10166 and did you also have SDK 10166 installed at the same time (before you were updated to Windows 10 OS Preview 10240)?
    2. Can you open a powershell prompt and type "Get-Service -Name *USB*" and tell me what that reports back?
    3. I've got a registry file on my OneDrive, can you apply that, reboot, and then tell me if the IP Over USB Service is re-enable?

    This will help me confirm what I think is going on and I think it will unblock you. If this works, for you, then I will get this posted as an issue so others can benefit.

    https://onedrive.live.com/prev?cid=88092d932b312c1e&id=88092D932B312C1E%21186636&authkey=%21ACy%5F%2Drwnx9gY5Pg&v=TextFileEditor

    Larry Olson



    Friday, July 17, 2015 12:50 AM

All replies

  • I am have the same issue too.
    Thursday, July 16, 2015 6:19 PM
  • Thanks for the info!

    This was a problem for other users too in a previous build: https://social.msdn.microsoft.com/Forums/de-DE/a0a82d5e-0fa7-4ec0-9748-e1763255f1a3/os-10162-do-not-have-windows-phone-ip-over-usb-transport-ipoverusbsvc-service-in-my-pc?forum=windowsstore

    Since Windows 10 Build 10240 is only available since yesterday I did not find any information about this problem beside from the thread above - let's hope, there will be a fix for this soon!!

    Seems the MS testing department does not test development for their own platform. :(


    • Edited by HannesBiri Thursday, July 16, 2015 6:39 PM
    Thursday, July 16, 2015 6:39 PM
  • I'm having the same problem after installing 10240.

    At least you save me some time reinstalling everything, but for now no WP development...

    Friday, July 17, 2015 12:00 AM
  • Hi Hannes,

    Can you try a few things for me.

    1. Were you on Windows 10 OS Preview 10166 and did you also have SDK 10166 installed at the same time (before you were updated to Windows 10 OS Preview 10240)?
    2. Can you open a powershell prompt and type "Get-Service -Name *USB*" and tell me what that reports back?
    3. I've got a registry file on my OneDrive, can you apply that, reboot, and then tell me if the IP Over USB Service is re-enable?

    This will help me confirm what I think is going on and I think it will unblock you. If this works, for you, then I will get this posted as an issue so others can benefit.

    https://onedrive.live.com/prev?cid=88092d932b312c1e&id=88092D932B312C1E%21186636&authkey=%21ACy%5F%2Drwnx9gY5Pg&v=TextFileEditor

    Larry Olson



    Friday, July 17, 2015 12:50 AM
  • It's fixed with the registry file.

    Since I was having the same issue, here are my results

    1. I did install that SDK (10166) when I was on build 10166. The app I was trying to debug was 8.0 Silverlight, so not sure if the SDK was relevant.

    2. The powershell command had no results

    3. ran the reg file, restarted, debugging once again works and the IpOverUsbSvc shows up when I run that powershell command

    Thanks for the help Larry


    • Edited by IshaiH Friday, July 17, 2015 1:22 AM
    Friday, July 17, 2015 1:22 AM
  • Hi Larry,

    thanks for your quick reply!
    Installing the registry key fixed the problem for me.

    1. Yes, I was on Windows 10 OS Preview 10166 and also had the SDK for Build 10166 installed at the same time before upgrading to Build 10240.

    2. No results

    3. Yes, now the service is shown in the list of services and it's running.

    Thanks for you help!
    I hope other developers will find this thread before spending the whole day trying to fix the problem...like I did. ;)

    best regards,
    Hannes

    Friday, July 17, 2015 5:17 AM
  • Perfect!!! option 3 worked for me *(Build 10240, vs 2015, Lumia 925)
    Saturday, July 18, 2015 4:14 PM
  • Thanks Larry. This registry fix worked perfectly.
    Sunday, July 19, 2015 3:27 AM
  • I also had this issue. The registry file was a success. Thank you very much.
    Tuesday, July 21, 2015 6:04 AM
  • After merging the registry file and restarting, this problem is solved for me as well.

    Thanks.

    Rob

    Sunday, July 26, 2015 5:48 PM
  • Thanks Larry! I had the same issue and it's already fixed now.
    Friday, July 31, 2015 6:07 AM
  • Hi Larry,

    I have the problem.

    I have applied the registry fix (but cannot see IpOverUsb in the list of services)

    I tried a reboot. I tried both SDK for 8.0 and 8.1.
    My device is a Microsoft 640XL with dual sim cards.

    My dev environment is on an activated version of Windows 10. I use VS 2015.

    Any ideas?


    Graeme.thomson@avaxa.com

    Monday, August 3, 2015 9:13 AM
  • Hi Larry,

    I have the problem.

    I have applied the registry fix (but cannot see IpOverUsb in the list of services)

    I tried a reboot. I tried both SDK for 8.0 and 8.1.
    My device is a Microsoft 640XL with dual sim cards.

    My dev environment is on an activated version of Windows 10. I use VS 2015.

    Any ideas?


    Graeme.thomson@avaxa.com


    Open Regedit. Find the key mentioned above. Look for ImagePath and see if you have that file on exact location. It might be on the different location on your device, one cause might be that this is a path for the 64-bit OS, it is slightly different for the 32-bit OS.
    Friday, August 14, 2015 11:54 PM
  • Go to search in Windows 8 and type "service" under settings, you will find "view Local services" and select it. It opens the services window.

    Alternately, Open Control Panel and select "Administative Tools" and you will find "Services" icon in it. Double clicking it also opens the Services window.

    After performing one of the above, Find the service with the name "Windows Phone IP over USB Transport (IpOverUsbSvc)" and right click on it and Start/Restart the service.

    Tuesday, October 6, 2015 5:14 AM
  • This fix has worked for me in the past. However, having upgraded to SDK 10563 today, and installing the Mobile Emulator, the IpOverUsbSvc executable appears to have been deleted during the installation.

    Is there anywhere I may be able to download it?

    Wednesday, October 14, 2015 12:48 AM
  • I recently updated to Windows 10 and Visual Studio 2015. I have a windows 8.1 device and Windows 8.1 runtime project. The powershell command returns the service 'Windows phone IP over USB' running. I applied the registry, restarted the PC, but I still find the same error. Please help.
    Wednesday, October 21, 2015 6:16 AM
  • hello there, thanks for sharing

    1. I dont know how to checkt whether it is a preview 10166 nor SDK 10166

    2. 

    Status   Name               DisplayName
    ------   ----               -----------
    Stopped  IpOverUsbSvc       Windows Phone IP over USB Transport...

    3. should i change all value for the whole types?


    Gifttra Pratama Robert

    Tuesday, January 5, 2016 6:44 AM
  • 

    I come here to bring solution that u might like I suggest you to try open service menu on your OS Windows as shown below

    on the form try to search Windows phone IP over USB Transport (IpOverUsbSvc)then u should right click and Start it then you may deploy your apps and see whether this solution works or no.


    Gifttra Pratama Robert

    Tuesday, January 5, 2016 11:22 AM
  • Thank you very very much....

    Saturday, March 19, 2016 2:57 PM
  • I am having same issue. This appeared when i updated Visual Studio 2015 Update 2 and deselected Universal Windows 10 development things. Unfortunately the proposed answer did not fixed the problem. This is a critical issue because i had a working instance of Visual Studio and the update 2 deleted this service without a reason.

    After downloading registry file as proposed and rebooted my system the registry showed up but if i try to run the service i get this error popup

    When i try to run the service

    Windows could not start the Windows Phone IP over USB Transport service on LocalComputer.

    Error 2: The system cannot find the file specified.


    Any fix?

    • Edited by Byron Gavras Tuesday, April 5, 2016 12:11 PM Not fixed
    Tuesday, April 5, 2016 11:59 AM
  • Option 3 from Larry Olsen's solution worked for me too, but I was also missing some executables like IpOverUsbSvc.exe which I had to manually copy over from a collegue who was still on VS2015 Update 1. That seems to have fixed it for now. Thanks for the help!


    Tuesday, April 5, 2016 4:02 PM
  • Solved that IpOverUsbSvc  issue...
    I faced this same problem this morning. I installed Xamarin and thus Visual Studio 2015 Update 2, which in turn deleted the service  IpOverUsbSvc somehow.

    Just download the Windows 10 SDK from 
    https://developer.microsoft.com/en-us/windows/downloads/windows-10-sdk

    Inside it there is a folder called
    Installers

    Inside that folder there are lots of .msi files and one of them is Windows IP Over USB-x86_en-us.msi

    Just install it. Then go back to the services windows, you will find the IpOverUsbSvc running.

    But now when I am trying to deploy my Windows 10 Universal App to my mobile, now I am stuck a new error,

    Severity Code Description Project File Line Suppression State Error DEP0001 : Unexpected Error: -2147023436

    Any idea? :P


    Thanks and Welcome :)




    • Edited by Suman Barick Saturday, May 28, 2016 1:52 PM Update
    Saturday, May 28, 2016 12:43 PM