none
The remote server returned an error: (502) Bad Gateway - System.Deployment.Application.DeploymentDownloadException (Unknown subtype) RRS feed

  • Question

  • Hi, I am trying to access an internal website (should not hit the proxy server) which returns a 502 error.
    URL : http://servername.xx.xxxxxxx.net:10610/any/thing/here.aspx

    The technical detail is that an entry in the proxyexceptionlist such as *.xxxxxxx.net will make IE connect directly to any URLs where the server ends in .xxxxxxx.net. Any servers that don't match an entry in the list will be forwarded to a proxy server instead as they will have visibility of the Internet.

    System.NET also uses this setting but where IE matched only the server name, .NET matches the whole URL before the third / which means that where a non standard port is specified (which is the case with virtually all web services) the match doesn't happen and the client goes to the proxy server - which returns the 502 error. An example of this would be that

    http://servername.xxx.xxxxxxx.net/test.htm would match the entry on the list but http://servername.xxx.xxxxxx.net:1720/webservice.aspx

    wouldn't.

    I know there are two solutions to this problem:

    1. to add the website to the proxyexceptionlist, but this will affect a lot of workstations, so I have to leave this one.

    2. To make a change in the .net application config file, so that it bypasses the proxy server, no matter what.

    I want to go with the second option but don't know what entries in the config file and can do this for me.

    The exact error info is below:


    Following errors were detected during this operation.
     * [19/02/2009 04:40:48] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
      - Downloading http://servername.xxx.xxxxxxx.net:10610/anything/goes/here.application did not succeed.
      - Source: System.Deployment
      - Stack trace:
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
       at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
       at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
       at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
       at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension)
       at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
      --- Inner Exception ---
      System.Net.WebException
      - The remote server returned an error: (502) Bad Gateway.
      - Source: System
      - Stack trace:
       at System.Net.HttpWebRequest.GetResponse()
       at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

    Please can someone help me with this. I have done a lot of research on the internet and you are the only option I have got. A quick response would be greatly appreciated.

    Thanks in advance,
    Monal

    Friday, July 17, 2009 10:59 AM

All replies

  • Hi Monal,

     

    I know this is quite an old post but ...

    Did you ever get this issue sorted? I am getting the same issue and am not finding any resolutions to it.

    Thanks, Neil.

    Wednesday, May 11, 2011 7:55 PM
  • Hi Monal,

    I know this is quite an old post but ...

    Did you ever get this issue sorted? I am getting the same issue and am not finding any resolutions to it.

    Thanks, Neil.

    Wednesday, May 11, 2011 7:55 PM
  • Try check for the proxy settings in your system. Sometimes, the proxy settings either disable the response or proper request string. Not sure thats the issue but!
    Aravind
    Monday, August 29, 2011 5:21 PM