none
Disable Clickonce Default Updater RRS feed

  • Question

  • Hi there,

    I've created a clickonce app that does its own clickonce updates programmatically (I've unchecked "The application should check for updates" in the Publish tab->Updates... in MSVS2008).

    However, once the app is installed and when I click on my app icon to launch it, the "clickonce updater" takes over, asking there's an update available, do you want to update? (OK/Skip).  Is there something else I need to do to disable clickonce from automatically performing updates?

    I never received this problem when publishing in the MSVS2005 environment.

    Thanks,

    Luke 
    • Changed type Bruce.Zhou Monday, February 23, 2009 10:27 AM Not followed up in time
    • Changed type Luke Hutton Monday, March 9, 2009 8:08 PM
    Saturday, February 14, 2009 12:24 AM

Answers

  • This behaviour is the side effect of calling CheckForDetailedUpdate API causing the update check result persisted in the registry without installing the update. The next time the user tries to launch the application through the shortcut, clickonce sees that there is an update and prompts the user.

    As a fix to this, the CheckForDetailedUpdate(bool persistUpdateCheckResult) API is introduced in 3.5 SP1 (.NET Framework 2.0 SP2) release. Calling CheckForDetailedUpdate(false) should resolve this issue.

    Thanks.
    Emel Simsek - MSFT
    • Marked as answer by Luke Hutton Tuesday, March 24, 2009 4:58 AM
    Tuesday, March 10, 2009 12:43 AM

All replies

  • Hi MrBlue13,

    I think it's enough to uncheck "The application should check for updates" in the Application Updates Dialog Box. So would you please check if you are doing something wrong? You can also try to remove the <subscription> tag from the deployment manifiest as an alternative. Please refer to Choosing a ClickOnce Update Strategy for more details.


    Best regards,
    Bruce Zhou

    Please mark the replies as answers if they help and unmark if they don't.
    Monday, February 16, 2009 7:00 AM
  • Did you ever deploy your application with the checkbox for checking for updates checked? Or has it always been unchecked?

    RobinS.
    GoldMail.com
    Ts'i mahnu uterna ot twan ot geifur hingts uto.
    Wednesday, February 18, 2009 5:13 AM
    Moderator
  • Thanks for the replies.

    @ Bruce: I searched for the "<subscription>" tags in the manifests when this occurred and found none.  I am following the same deployment process I have been for a while and this scenario only seems to happen once in a while when publishing from VS2008.

    @ Robin: No, the checkbox has always remained unchecked.

    My co-worker was recently developing some new features with our custom ClickOnce updater (adding progress bar, status, etc. to a wait dialog) and he also found the same result I did.  Out of 40 test deployments, he was opening the application from the Start Menu, and he only once received the ClickOnce update prompt and the other 39 times, our custom updater ran.  No changes were made to any publish settings. 

    Any other suggestions?

    Thanks,

    Luke
    Wednesday, February 18, 2009 11:32 PM
  • Hi MrBlue13,

    If you couldn't find the <subscription> tag, the application shouldn't check for updates. Did you mean most of the time the clickonce application will not prompt updates, but only occasionally.

    I am not sure it's an issue about the product, did you apply the latest service package for the Visual Studio 2008. If not, try and check if the problem can be solved.

    Best regards,
    Bruce Zhou 


    Please mark the replies as answers if they help and unmark if they don't.
    Thursday, February 19, 2009 7:17 AM
  • We are changing the issue type to “General Discussion” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by opening the Options list at the top of the post editor window, and changing the type. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.


    Please mark the replies as answers if they help and unmark if they don't.
    Monday, February 23, 2009 10:26 AM
  • Hi Bruce,

    Sorry, we just upgraded to MSVS 2008 SP1 and tested the deployment and the problem still persists.  Only sometimes the clickonce application prompts for updates using the default clickonce update mechanism.  We are not sure why this is happening, can you suggest any other troubleshooting techniques or something we may be doing wrong with our publishing? Let me know if more information is required.

    Thanks,

    Luke
    Monday, March 9, 2009 8:07 PM
  • This behaviour is the side effect of calling CheckForDetailedUpdate API causing the update check result persisted in the registry without installing the update. The next time the user tries to launch the application through the shortcut, clickonce sees that there is an update and prompts the user.

    As a fix to this, the CheckForDetailedUpdate(bool persistUpdateCheckResult) API is introduced in 3.5 SP1 (.NET Framework 2.0 SP2) release. Calling CheckForDetailedUpdate(false) should resolve this issue.

    Thanks.
    Emel Simsek - MSFT
    • Marked as answer by Luke Hutton Tuesday, March 24, 2009 4:58 AM
    Tuesday, March 10, 2009 12:43 AM
  • Thanks Emel,

    I have updated our call from ApplicationDeployment.CurrentDeployment.CheckForDetailedUpdate() to ApplicationDeployment.CurrentDeployment.CheckForDetailedUpdate(false).

    I will mark this question as answered once found resolved after a few tests.

    Cheers,

    Luke
    Tuesday, March 10, 2009 10:56 PM