none
Visual Studio and MSAccess RRS feed

  • Question

  • Changes made to the schema in MSAccess are not reflected in the Visual Studio project. 

    How do I get the schema changes to reflect?  I do not have the database copied in the

    project and in the BIN directory there are only two directories - Debug and Release.

     

     

    Saturday, September 29, 2007 10:21 AM

Answers

  • no its not visible as the schema is not updated and is still referring to the last modified/created schema. you need to re-update/create the tableadapters again through the wizard in order for it to see the changes.

     

    Saturday, September 29, 2007 7:29 PM
    Moderator

All replies

  • Can you explain more by what you mean about the schema not changing/reflecting in VS project? How are you doing this initially? What are you doing?

    Saturday, September 29, 2007 2:28 PM
    Moderator
  • First I created the database using MSAccess.

    Forms were created in Visual Studio using data linked to the connections to the MSAccess database.

    I closed Visual Studio.

    In MSAccess fields were added, existing field names changed.

    Open the project in Visual Studio. The changes made in MSAccess are not picked up by the database connection.

     

    I haven't figured out what needs done to see those changes.  I'm working with one database, not having it copied in the project.  Any suggestions are appreciated.

     

    thanks

    Saturday, September 29, 2007 6:08 PM
  • sorry, what code are you using? Are you using tableadapters (using the Database wizards? If so, then of course, it won't do that - you will need to recreate the tableadapters again via the wizard.

    Saturday, September 29, 2007 6:33 PM
    Moderator
  • I am using the wizard to create the table adapters.  If I make the connections with code will the changes made in MSAccess be visible in the data connections?

    Saturday, September 29, 2007 7:01 PM
  • no its not visible as the schema is not updated and is still referring to the last modified/created schema. you need to re-update/create the tableadapters again through the wizard in order for it to see the changes.

     

    Saturday, September 29, 2007 7:29 PM
    Moderator
  • Thank you so very much.  I'll play around with that for a while and will try making the connection in code.  It was very convenient using the connected dataset from the wizard to create the text boxes on the forms.

     

    Saturday, September 29, 2007 7:44 PM
  • You may also want to check the FAQ to see if one of the issues applies to your problem:

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=427451&SiteID=1

     

     

     

    Monday, October 1, 2007 12:43 PM