none
Microsoft.Reporting.WinForms.ReportViewer is not defined on MS Build Server RRS feed

  • Question

  • got Microsoft.Reporting.WinForms.ReportViewer  is not defined error on MS Build Server 2015 when i try to build clickonce windows application. i already try to with nugget  Install-Package microsoft.ReportViewer.WinForms. 

    still not works. please help.

    Thanks

    Thursday, April 20, 2017 3:40 PM

All replies

  • Hi dehui,

    Thanks for posting here.

    This forum is about the MSBuild ,(usage of MSBuild, build customization, and MSBuild extensibility via tasks, loggers and hosting), as your issue is more related to the ClickOnce and Setup & Deployment Projects, we help you move it to the ClickOnce and Setup & Deployment Projects forum for better support.
    Thank you for your understanding.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 21, 2017 6:23 AM
  • Hi dehui,

    Sorry for the late reply.

    >>got Microsoft.Reporting.WinForms.ReportViewer  is not defined error

    This is a common error, and the most likely reason is that the reference path is not defined correctly, so please refer to the following step to solve it:

    1, Find the Microsoft.ReportViewer.WinForms Reference and find the path property:

    Then check the path, the most likely reason is this path is not defined correctly.

    2, Please remove the reportViewer control from your form and remove the reference via right click then re-add it by manually.

    3, Please re-add the reportViewer from the toolbox.

    Also you can refer the following link that has similar problem:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/9403f88c-e091-4a9e-a398-cae400bf1c9a/microsoftreportingwinformsreportdatasource-is-not-defined?forum=vbgeneral

    http://stackoverflow.com/questions/39392871/vb-net-microsoft-reporting-winforms-reportviewer-is-not-defined

    Hope it helps!

    Best Regards,

    Stanly


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 24, 2017 8:26 AM
    Moderator
  • The problema is the framework, update it to versión 4.61.

    I hope it helps you.

    Saturday, November 23, 2019 7:34 PM