locked
ClickOnce installer fails to get app RRS feed

  • Question

  • I have used ClickOnce to deploy my app to a file share on a server in my intranet. That folder is under a webserver root so I want my users to go to http://someserver.dom.com/App/Publish.htm and to get the app from there.

    This does not work.

     

    Browsing to that URL brings up the correct generated webpage and clicking on the Install button starts the installer (MyApp.application). But then it says:

    "Cannot download the application. The application is missing required files..."

    The log files says:

      + Downloading http://xx.xx.1.27/MyApp/Application Files/MyApp_1_0_0_10/MyApp.exe.manifest did not succeed.
      + The remote server returned an error: (404) Not Found.

    Looking in the webserver logs, it is trying to download files that have "App/Application+Files/MyApp_1_0_0_10/" in them. I have no idea why the plus sign is in there. It should be a space or a %20.

     

    I am unable to find where and how VS generates the "Application Files" path, so I can't change it to something else, it seems to be hard-coded.

    Any ideas?

     

    - Lutz

    Wednesday, October 29, 2008 5:30 PM

Answers

  • Lutz,

     

    Did you register the correct MIME types in IIS? You can find info about this in the following posts in http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=4020085&SiteID=1 . It ist possible that *.deploy, *.manifest, *.vsto may not be recognized and will not be served by IIS.

     

    -Stepple

    Thursday, October 30, 2008 9:46 PM
  • A couple of questions.

     

    First, when you deploy it, are you setting the publishing location to the fileshare, or deploying to http://whatever/?

     

    If you are publishing directly to the fileshare, are you setting the Install Location URL to http://whatever in the deployment?

     

    Third, the other post is correct; you need to make sure you have the MIME types are defined on the server.

     

    For ClickOnce:

    .application  --> application/x-ms-application
    .manifest  --> application/x-ms-application
    .deploy   --> application/octet stream

    If deploying .Net 3.5:

    .msp --> application/microsoftpatch
    .msu --> application/microsoftupdate

    If deploying a VSTO application:

    .vsto --> application/x-ms-vsto

     

    The actual error is a 404 error, file not found. To me, this indicates that your users do not have the privilege to read the application files folder under the deployment location. You should talk to whoever supports that server and ensure that the MIME types are set up, and that regular users have read access to the root deployment folder and all the files and folders within.

     

    RobinS.

    GoldMail.com

     

    Friday, October 31, 2008 3:55 AM

All replies

  • Lutz,

     

    Did you register the correct MIME types in IIS? You can find info about this in the following posts in http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=4020085&SiteID=1 . It ist possible that *.deploy, *.manifest, *.vsto may not be recognized and will not be served by IIS.

     

    -Stepple

    Thursday, October 30, 2008 9:46 PM
  • A couple of questions.

     

    First, when you deploy it, are you setting the publishing location to the fileshare, or deploying to http://whatever/?

     

    If you are publishing directly to the fileshare, are you setting the Install Location URL to http://whatever in the deployment?

     

    Third, the other post is correct; you need to make sure you have the MIME types are defined on the server.

     

    For ClickOnce:

    .application  --> application/x-ms-application
    .manifest  --> application/x-ms-application
    .deploy   --> application/octet stream

    If deploying .Net 3.5:

    .msp --> application/microsoftpatch
    .msu --> application/microsoftupdate

    If deploying a VSTO application:

    .vsto --> application/x-ms-vsto

     

    The actual error is a 404 error, file not found. To me, this indicates that your users do not have the privilege to read the application files folder under the deployment location. You should talk to whoever supports that server and ensure that the MIME types are set up, and that regular users have read access to the root deployment folder and all the files and folders within.

     

    RobinS.

    GoldMail.com

     

    Friday, October 31, 2008 3:55 AM