Add Connection, test connection fails Error: 26


  • Trying to add a connection to a SQL Server 2008 file on the local machine using the data source configuration wizard, Selecting "Database" then "Dataset" and "New Connection"... set the source as Microsoft SQL Server Database file, selecting the file name in the add connection dialog, hit Test Connection and it fails "provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified" Tried it using C# 2010 Express and VB 2010 Express with same result.

    Checked the advanced properties, Source shows correct filename and path, and Data Source .\SQLEXPRESS

    machine is XP pro Sp3

    Any ideas??



    Sunday, November 20, 2011 3:08 PM

All replies

  • on further investigation... there was nothing associated with SQLEXPRESS in the services list.. I uninstalled all the SQL express components and C# express, then reinstalled, now there are several services involved with SQL express in the services list... however... they are not started and when I try to start,

    The SQL Server (SQLEXPRESS) service terminated with the service-specific error 17058 (0x42a2)

    checked permissions and turned off antivirus and firewall... still the same... hmmmmm

    going to try uninstall, delete old folders and reinstall... see if that helps

    Tuesday, November 22, 2011 2:57 AM
  • Hi Nodthenub,

    Welcome to the MSDN Forum.

    How is it going after reinstall the SQL Server? Have the issue solved now?

    This article may help to install SQL Server 2008: .

    Best Regards,

    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us
    Tuesday, November 22, 2011 7:56 AM
  • Hi Bob,


    Thanks for the tip! the article did help.. the install was more hands on than the one i'd been using, and gave me more info to work with..


    The problem still exists though...

    Looks like it's related to the MSDTC service, the SQL Server install reported that a registry entry was missing for MSDTC, and sure enough, it isn't there... the file MSDTC.exe is sitting there in the system32 folder, but the service won't start... looks like a registry corruption might be the culprit, just checking out what I need to do to fix it..


    Wednesday, November 23, 2011 3:49 AM
  • Hi,

    Please try to reinstall MSDTC,

    Best Regards,

    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, November 23, 2011 3:59 AM