file access is denied


  •  Error 1 Could not create the file 'C:\Users\Mark\AppData\Local\Temp\VSI4A84.tmp' 'Access is denied.' C:\Users\Public\My Documents\Visual Studio 2008\InventoryData\SetupApp\SetupApp.vdproj SetupApp

    This happens everytime I try to build a setup project where the output is to a compressed setup file.  What's the deal?

    Tuesday, February 17, 2009 4:56 AM

All replies

  • Hi,

    The reason of this problem may be that another process is using the VSI4A84.tmp file. Perform a try deleting all files under the folder C:\users\mark\AppData\Local\Temp to see if the problem can be fixed.

    If the problem still exists, restart the computer to see if it can solve the problem.

    Hope this helps.

    Linda Liu

    Wednesday, February 18, 2009 7:52 AM
  • Hello, I did delete the files in the temp folder, however, I am still getting the error.
    Wednesday, February 18, 2009 4:59 PM
  • Hi,

    Please have a try restarting the machine to see if the problem can be fixed.

    Linda Liu

    Thursday, February 19, 2009 4:05 AM
  • Right Click the Temp folder and remove readonly attribute
    • Proposed as answer by Kenky Dude Friday, March 06, 2009 6:46 AM
    Thursday, February 19, 2009 7:21 AM
  • The only thing I found that works reliably so far is to use the clean solution option.  The other one is to compile a project with a know error, for some reason that works, also tells me I might be running out of memory.

    Thursday, February 19, 2009 3:20 PM
  • Hi OpenXmlMadCoder,

    > The only thing I found that works reliably so far is to use the clean solution option. 

    Do you mean the problem is solved by using the menu Build | Clean Solution?


    Friday, February 20, 2009 3:09 AM
  •  Yesterday it was working, now I switched to not compressing the files into a cabinet or setup application.  So the setup application properties is set to Package Files : As loose uncompressed files.  I assume the packaging program is a separate process.
    Friday, February 20, 2009 3:16 AM
  • i had this problem too... the reason of this problem maybe is your antivirus application. you shoud stop your antivirus for solve the problem.

    i did that and the problem solved.

    Tuesday, August 31, 2010 7:02 AM