Error in creating hyperledger fabric channel with only orderer organization RRS feed

  • Question

  • ./azhlf channel create -c $CHANNEL_NAME -u $ORDERER_ADMIN_IDENTITY -o $ORDERER_ORG_NAME

    Error is returned when executing create channel command. Followed the steps in https://docs.microsoft.com/en-us/azure/blockchain/templates/hyperledger-fabric-consortium-azure-kubernetes-service#create-channel-command

    2020-05-22T09:48:29.332Z - error: [Remote.js]: Error: Failed to connect before the deadline URL:grpcs://xxxxxx.westus.aksapp.io:443
    2020-05-22T09:48:29.334Z - error: [Orderer.js]: Orderer grpcs://xxxxxx.westus.aksapp.io:443 has an error Error: Failed to connect before the deadline URL:grpcs://xxxxxx.westus.aksapp.io:443

    Region for both Orderer and resourcegroup are set to westus. We have already deleted and remake previous setup, where region was set to australiasoutheast, thinking region might be the cause. But still the same error is encountered in channel creation even though region is changed to westus.

    Node size: Standard B2s

    Region: westus

    Can you help us pinpoint what went wrong. 

    Thank you.

    Friday, May 22, 2020 10:31 AM

All replies

  • Hello,

    Apologies for the delay in response. Are you still facing this issue? 

    Could you please retry now and report if you are still blocked? 

    Thursday, May 28, 2020 12:19 PM
  • Hello,

    Just checking back to see if you are still blocked and need further help. This could be a transient failure and retry could help resolve the issue.

    Monday, June 1, 2020 1:11 PM
  • Hi,

    Yes. Encountered same error until now.

    Friday, June 5, 2020 12:46 AM
  • Hi,

    Yes. Encountered same error until now. Can you share more information about this? Is it related to the region or nodesize?

    Friday, June 5, 2020 12:48 AM
  • Thanks for confirming. I am checking on this issue internally and update you as earliest.

    Apreciate for your time and patience.

    Friday, June 5, 2020 1:35 PM
  • Thanks for checking on this. Keep us posted.
    Monday, June 8, 2020 12:39 AM
  • Hello @ascii20200522

    Please reproduce the issue and run below steps to collect the logs from deployment. These steps can be run from azure cloud bash shell.

    1. curl https://raw.githubusercontent.com/Azure/Hyperledger-Fabric-on-Azure-Kubernetes-Service/master/scripts/AksHlfTroubleshooting.sh -o AksHlfTroubleshooting.sh; chmod 777 AksHlfTroubleshooting.sh
    2. This command will create a zip file containing all the logs in the current directory.

    ./AksHlfTroubleshooting.sh <myTemplateDeployment-SubscriptionID> <myTemplateDeployment-ResourceGroup> <myTemplateDeployment-aksClusterName> “orderer”

    Once you collect the logs, please send us @ AzCommunity@microsoft.com along with this MSDN issue link to help you further.

    Note: Please re-direct all your responses/queries to Microsoft Q&A forum from here on-wards.

    Please include reference to this MSDN thread if you would like to continue the discussion on Microsoft Q&A forum. We would be happy to help you!

    Monday, June 15, 2020 7:00 AM