none
Regarding Remote Access of WMI Commands RRS feed

  • Question

  • Hi,

    i am trying to read the information from a remote Machine (Network shared Machine) using WMI Command but i am getting Access issues

    Error Message : 

    get-wmiobject : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Get-WmiObject], UnauthorizedAccessException
        + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

    Command which i tried is : 

    get-wmiobject Win32_BIOS -Computer 192.168.8.118

    Here 192.168.8.118 is my Client System IP address

    if i tried to Ping this IP from my System (Host) I am able to getting reply back

    Can some one please help how to resolve this issue

    Tuesday, November 19, 2019 7:06 PM

All replies

  • Hi MagiUma,

    The cause of this error is DCOM may not be configured to allow a WMI connection.

    You can configure DCOM settings for WMI using the DCOM Config utility (DCOMCnfg.exe) found in Administrative Tools in Control Panel.

    More details you can refer to this document.

    [Troubleshooting a Remote WMI Connection]

    About “Remote Access of WMI Commands”, this document may be useful for you.

    [Connecting to WMI Remotely with PowerShell]

    You can also refer to the following similar issue.

    [Powershell Get-WmiObject Access is denied]

    Best Regards,

    Daniel Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 20, 2019 2:15 AM