[bug] Task fields not displayed properly inside eclipse editor on project that uses Microsoft Visual Studio Scrum 1.0 process template


  • Hi,

    I'm using TEE on eclipse 3.7 (SpringSource Tool Suite 2.7.2.RELEASE).

    Here is my scenario:

    1) in team explorer open team project that uses Microsoft Visual Studio Scrum 1.0
    2) right-click work items -> new work item -> task
    3) fill task title, assigned to (set to valid developer name), state (set to 'to do'), description fields
    4) save task, close form
    5) use query to list all user tasks : created task is visible; task field values in list are displayed correctly (e.g. title, assigned to, state)
    6) open created task from list by dbl-clicking on task

    Result: task editor is displayed in eclipse, but some field values are missing: 'assigned to' and 'state' are empty and do not display saved values.
    Expected: all saved task fields are displayed correctly.

    When same task is opened using open with -> external browser and task is displayed inside my browser all task field values are displayed correctly as expected.

    The same bug does not happen when creating/opening bug or product backlog work items on the same project.
    Also, bug does not happen when creating/opening work items on project with MSF for Agile 5.0 process  template.





    2011年10月25日 下午 12:16


  • Hi Mario,


    I will try to repro the issue and get back to you. Meanwhile, I have a question for you have you update the work item definition for the task or you are using the default definition?





    2011年10月25日 下午 03:03
  • Hi Mario,


    I was not able to repro this issue but I noticed one thing, you are talking about the "Assigned To" and this is not shown in the form, however you can see it when you run the query. What you can see in the form is the "Owned by" field. Those are two different fields that don't have the same value. As for the state field, the value I saw in the query result is the same value that I got when I double clicked the work item to open the form.




    2011年10月25日 下午 05:09
  • Hi Mireille,

    Thank you for you answer.

    As far as I know we are using the standard MS Scrum v1.0 process template, no customization was performed, running TFSv2010.

    When I open the task in eclipse, task form shows me 'Assigned to', 'State', 'Reason' and 'Blocked' fields grouped inside 'Status' group - text boxes of 'Assigned to:' and 'State:' are empty although I have valid values in those fields and they are displayed correctly in my query result list, when I open the task in visual studio and using web access. I do not see 'Owned by' field anywhere on the task form.

    If I set the empty 'State:' field to 'To Do' I do not get the asterisk sign in the task window title box indicating task was modified (actual value of this field is 'To Do'). If I set this field to 'In progress' I get the asterisk and 'Assigned To:' field suddenly displays the correct value. When I save and reopen my task both 'Assigned to:' and 'State' fields are empty.

    I tried opening the same task using other eclipse environments, here are my findings:

    1) Eclipse Helios Service Release 1 (3.6.1.r361) + TEE : no bug, all field values are displayed as expected

    2) Eclipse Indigo Release (3.7.0.v20110530) + TEE : bug is present, same as described above, field values missing

    I'm running windows 7.

    Hope this helps.



    2011年10月25日 下午 10:36
  • Hi Mario,

    I think the "Owned By" vs. "Assigned To" issue that Mireille raised was due to the fact that Mireille was using a Scrum project that had been created by a Beta version of the scrum templete.   I've created a new team project using the "MS Scrum v1.0" process template that you mentioned and am trying to reproduce the error.

    I'm having trouble reproducing the error.

    I'm on Windows 7.  I've tried..

    Eclipse 3.6 + TEE 10.1

    Eclipse 3.7 + TEE 10.1

    Eclipse 3.7 + TEE 11.0


    The fact that you say the asterisk doesn't show when you change "Assigned To" from empty > Todo indicates that the form knew the current value for the field was set to Todo.. and in fact, it's not possible to save a task with an empty state field (as the field is required).

    Im curious, in the repro steps from your first messation you mentioned "set State to 'to do'.   Was the state field empty for you when you initially created the new task?  When I create a new task I see that the state field is already pre-populated with 'to do'.


    2011年11月3日 下午 06:00