Visual Studio 11. Orderedtest not showing in the Unit test explorer.


  • Hello,

    Perhaps this is a simple issue. But i just can't get the hang of it.

    I've recently installed Visual Studio 11 Ultimate Beta. And now when i open my solution all of my orderedtests are not showing up in the Unit Test Explorer. Or is there another view I can find these tests in?

    Anyway, I tried to add a new ordered test, and when i started the build I get the following output.

    "No plugin found which can import settings file with extension '.orderedtest'. Either select a new settings file or install an extension which understands this settings file extension."

    Have tried to search for this issue but can't find anything. Anyone who had the same issue? An perhaps know a sollution for this?'

    Best Regards


    28 Maret 2012 7:19


Semua Balasan

  • Hi Jonas,

    As what I have try, the orderd test could be recognized well by Unit test explorer, but this process would take a few minutes and there isn’t any exception occur like what you’re described during building.

    Please refer to the following link about create an ordered test in VS 11:

    Hope this could help.

    Tony Xiao [MSFT]
    MSDN Community Support | Feedback to us

    29 Maret 2012 9:16
  • Hello Jonas,

    This error message which you are getting is raised if you "select" a .orderedtest file in the unit test explorer (Unit test -> Unit test settings -> select the settings file). Can you please check whether in your case, an ordered test file was selected or not? If yes, please deselect it and see whether it works or not.


    Aseem Bansal

    25 April 2012 11:58