How can I fix this error - Unable to load DLL 'Roslyn.VisualStudio.Services.Interop.dll' ?


  • I was trying to debug a sample project (ConvertToAutoPropertyCS) when this error message popped up:-

    Unable to load DLL 'Roslyn.VisualStudio.Services.Interop.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

    This error seems to be popping up for other sample projects too which used to work fine earlier. I am not sure what changed.

    How can I fix this?

    Nikhil Agarwal
    mardi 22 novembre 2011 21:18

Toutes les réponses

  • That is strange. I tried to reproduce the error by debugging / running the same sample on my machine but with no luck. When does the error pop up - is it when you build the project / when you run it / when you debug it? Could you please post a screenshot?

    Have your tried rebooting the machine to see whether that fixes it? If that doesn't work then perhaps reinstalling the CTP may fix this - but you may want to back up any source changes you may have made to the samples etc. before you do this...

    Shyam Namboodiripad | Software Development Engineer in Test | Roslyn Compilers Team
    mercredi 23 novembre 2011 00:35
  • It occurs when I try to open an existing project in the visual studio instance that starts up when I am debugging a sample project. I was able to debug these projects earlier but for some reason, this error has started popping up now.

    I will try rebooting the machine and see if it helps. Reinstalling the CTP didn't.


    Nikhil Agarwal
    mercredi 23 novembre 2011 01:13
  • Try going under the following folder on your computer (remove the "(x86)" as appropriate)

    C:\Program Files (x86)\Microsoft Codename Roslyn CTP\Extensions\

    and run the program named "Roslyn.VisualStudio.LanguageServices.Installer.exe". There is no UI that it pops up, so just run it and wait until you no longer see it in the task manager and then restart your Visual Studio instances.

    mercredi 23 novembre 2011 17:07
  • Hi Nikhil - Any updates about this issue? Were you able to determine the root cause? Did the workarounds suggested by me / Jason work?
    Shyam Namboodiripad | Software Development Engineer in Test | Roslyn Compilers Team
    mercredi 4 janvier 2012 01:22
  • Both approaches didn't work. I still get the same error.

    However, just running the project works fine (Ctrl + F5 instead of F5). This is why it used to 'work' earlier for me because I was running the project instead of debugging it.

    Nikhil Agarwal
    mercredi 4 janvier 2012 02:17