Blanks being stripped from field names in WIT definitions - causing errors during template upgrade


  • I tried to add enough detail, but let me know if you need more.  Some details I cannot provide because some of the configuration happened before my time, alas. 

    Short version: We originally had a TFS 2008 SP1 instance, and we did an in-place upgrade to TFS 2010 w/SP1.  In January, I setup up new hardware, did a fresh install of TFS 2010, and then migrated the collection from the old server to the new server - THIS WAS IMPORTANT TO NOTE.  There are 2 TPCs on this new instance.  One that has all of the old TFS 2008 TPs on it, as well as some new TFS 2010 TPs.  I have another TPC that I created as a sandbox with nothing but a single fresh TFS 2010 TP on it.  I am attempting to upgrade some of the customized Agile 4.2 TPs to Agile 5.0 by following this MSDN post:

    I got to skip a portion at the beginning since some assets existed already (link types and categories) and went right to the part where you add Shared Steps and TestCase work item types to the TPs you are upgrading.  This is where things got weird. I wasted a lot of cycles thinking I screwed up my templates because things kept failing on import and I wanted to understand why before I went changing field names and uploading it. I ran into this error on about half a dozen fields in both SharedStep and TestCase work items: “TF26177: The field System Iterationld cannot be renamed from ‘IterationlD’ to ‘Iteration ID’.”

    Now I’ve read the blogs, I’ve seen lots of other people complaining about it too, but I’d love to see some answers so I understand better why this is happening and can avoid it in the future. I get that the product team changes things between versions, fine.  Usually those are documented, somewhere.  But why is it that when I create a new TFS 2010 team project from an Agile 5.0 OOB process template, THOSE new TPs don’t match the template I just used to create it?  See below where I created a new Agile 5.0 TP (on right) from the standard Agile 5.0 process template (on left) and quite a few field names are different because of the blank space suddenly disappearing (IterationID, ExternalLinkCount, RelatedLinkCount, etc.):


    I talked to a lot of folks using TFS in the field, including 2 TFS rangers, and most of them never encountered this problem and I might know why.  Bear with me for a few more sentences.

    I’m still learning, so what I ended up doing - which was probably NOT best practice- was exporting the work item types that I needed to add to my legacy team projects from the new team projects.  I probably should have exported them from the original process template itself, but hindsight is 20/20.  So I added new work item types that had names with no blanks in them, which does NOT match the original template.  At this point I did not realize that was what I was doing. Then I started running into some other issues and decided to start over and re-import the SharedStep work item type from the Agile 5.0 process template instead.  So I was trying to over-write a SharedStep that had field names with no blanks in them with a work item template that DID have blanks in the field names. I didn’t think it mattered where I exported/imported the SharedStep XML from because THEY SHOULD BE THE SAME RIGHT? No, apparently not. 

    So, anyone know why TFS would strip blanks out of field names in a work item template when it created the fields in my team projects? This only happenned on the TPC that had been migrated from a previously upgraded (from TFS 2008) server.  When I opened a SharedStep work item XML from the new TPC there was no difference between the original work item template and the new team project work item definiteion.  I only see differences on the upgraded project.  Weird...

    Angela Dugan

    viernes, 23 de marzo de 2012 21:36


Todas las respuestas