localhost/ no longer responds (wcf and iis)


  • I'm not sure what has changed in my environment (nothing was intensionally changed), but IIS and my self hosting WCF application no longer respond when I browse localhost or in a web browser on the same machine.  If I enter the ip address of the machine I am on, IIS and my self hosting WCF application respond just fine.

    This may be a larger system issue and not specific to WCF since I am also seeing it with IIS, but I'm not sure how related IIS and a self hosting WCF app are so I figured I would post here as a start.

    I'm not aware of any changes to my pc.  Everything was working fine yesterday, and I just noticed the issue today.  I tried rebooting but that did not solve it.

    I can successfully ping localhost and

    I am on a Vista x64 machine.

    Thursday, May 14, 2009 6:38 AM

All replies

  • Hi ,Johnny
    1.make sure your WCF service application are running sucessfully,In IIS,restart your WCF application,right calick your it and view in browser .
    2.check the IIS WCF service application  port is corect,if not 80, you can set a new port for this WCFa pplication.
     try it again~
    Frank Xu Lei
    you have a dream,you gonna protect it!
    Saturday, May 16, 2009 8:09 AM
  • You could also try iisreset.
    Tuesday, May 19, 2009 5:53 PM
  • Thanks for the replies.  Yes I have tried all of those with no success.  I think this issue is bigger than just WCF.

    All of the following fail:

    However this works:

    However I can successfully ping all of those.

    It's just the local host stuff that doesn't work.  I'm wondering if something has corrupted my network setup.  Perhaps I should post this in a different forum?

    Friday, May 22, 2009 5:59 AM
  • Also I have a separate web server running on a port 9000. I can successfully navigate to and http://localhost:9000/.  However this is not IIS and not WCF, but it does prove that localhost and work in the web browser.  So there must be something messed up in IIS... doesn't WCF sit on top of IIS?

    Friday, May 22, 2009 6:28 AM
  • I believe I have solved the problem.

    I ran: netsh http show iplisten

    which resulted in:

    IP addresses present in the IP listen list:

    I compared this with another Vista machine which had a blank list.  So I used the netsh command line tool to remove from the list and things are now working.

    The big question now is:  HOW did that IP address get in the listen list, and how does this list differ from the web site binding in IIS Manager (besides having no port)?

    Friday, May 22, 2009 7:52 AM