none
Search in Project Portals doesn't work

    Question

  • Hi there,

     

    On our TFS installations the Search-Option is not working, although the field is on the portal sites. All we get is Your search cannot be completed because this site is not assigned to an indexer.

    The reason lies probably in the fact that I can't configure WSS search at all in Sharepoint Central Administration, it won't show a Search component no matter what I try. I tried to start the indexing services on the server, succeeded in it, but still no search component in Central Administration.

     

    If I go to Central Administration | Application Management | Content Databases, choose WSS_Content (the only entry), the field Search Server is greyed out. Is WSS-Content what I'm looking for or is there another database which should be selected, if so how would I do that (especially on a one-tier machine).

     

    We have got one TFS as a single tier and one as a 2-tier-installation. Same picture regarding the search anything else works fine.

     

    I look for any solutions on the web but came up shorthanded.

     

    Can anybody help me? Please?

     

    Thanks in advance.

     

    Yours truly, Fred

     

     

    Wednesday, March 05, 2008 9:48 AM

Answers

  • Hi there,

     

    This solved my search problems:

    1. Open SharePoint Products and Technologies Configuration Wizard, confirm all Windows with YES, OK and FINISH, settings stay default
    2. Central Administration | Operations | Topology and Services |Services on Server, "Windows SharePoint Services Search" Click on Start, configure the accounts and settings appropriately
    3. Central Administration | Applications Management | SharePoint Web Application Management | Content Databases, click on "WSS_Content", in "Select Windows SharePoint Services search server" click on the drop down field and select your server
    4. Finally I restarted the services IIS and Windows SharePoint Services Search (don’t know whether that’s necessary or not)

    I hope I haven't forgot a step... Maybe you can post whether it helped you, too.

     

     

    Yours truly, Fredo

     

    Thursday, March 13, 2008 12:53 PM

All replies

    1. What version of TFS are you on?
    2. What version of WSS are you on or are you trying MOSS?
    3. Are you searching from the team project portal or the localhost site page?
    Thursday, March 06, 2008 3:04 PM
  • Hi Shawn,

     

    1. TFS 2008  (one single- and one 2-tier)

    2. WSS 3.0

    3. I'm searching from the team project portal.

     

    Thanks!

     

     

    Yours truly, Fredo

     

    Thursday, March 06, 2008 3:17 PM
  • We're a version behind in our test environment, but only by a few weeks!  That doesn't help you though.  There are lots of posts about indexer services.  One mentions a 'restore indexer defaults' option you might try.

    Monday, March 10, 2008 2:44 PM
  • We have the same problem. TFS 2008 on a single server and the search is not functioning.

     

    Sharepoint Search Service is running, but on the Sharepoint Management Website there is the search indexer dropdown greyed out.

     

    Wednesday, March 12, 2008 3:00 PM
  • Hi there,

     

    This solved my search problems:

    1. Open SharePoint Products and Technologies Configuration Wizard, confirm all Windows with YES, OK and FINISH, settings stay default
    2. Central Administration | Operations | Topology and Services |Services on Server, "Windows SharePoint Services Search" Click on Start, configure the accounts and settings appropriately
    3. Central Administration | Applications Management | SharePoint Web Application Management | Content Databases, click on "WSS_Content", in "Select Windows SharePoint Services search server" click on the drop down field and select your server
    4. Finally I restarted the services IIS and Windows SharePoint Services Search (don’t know whether that’s necessary or not)

    I hope I haven't forgot a step... Maybe you can post whether it helped you, too.

     

     

    Yours truly, Fredo

     

    Thursday, March 13, 2008 12:53 PM
  • Hi Fredo

     

    That solved the problem.

    I had to restart IIS and WSS Search (Step 4). The search was active but there were no result. After a restart everything worked. Thank you!

     

    Thursday, March 13, 2008 2:04 PM
  •  

    This worked for me too. Thank you.

     

    Cheers,

     

    Kate

    Thursday, April 03, 2008 3:19 PM
  • I have the same issue...

     

    Using the steps above I ran the wizard and selected everything that was already setup.

    It ran through 8 steps, which I noticed one was creating the search service.

     

    Now it's completed, and it says that the "Service Unavailable" when trying to browse the admin site.

     

    The portals for the project sites still work correctly though.

     

    EDIT>>>>>>

    According to the logs, the Identity for the Share Point app pool was incorrect (after running the wizard). That was actually the first thing I checked, and it had the old domain\user and password entered already. This was one I configured at TFS setup (NOT the default for the pool).

     

    I retyped the credentials anyway with the same data, restarted the pool and site and it now works.

     

    Now under the Service on Server I have the search Smile

     

    thanks !

     

     

     

    Wednesday, May 14, 2008 12:09 AM