locked
How can I remove localization information from my WPF project? RRS feed

  • Question

  • Hi,

    when compiling my project, the compiler generates somewhere around 10 folders (ko, jp, de, en, es,...) which are stuffed with localization resources. In Winforms, as far as I recall, this happened when you set your Form localizable...

    Can anybody tell me where I can locate the switch that turns this off?

    Thanks a lot in advance

    Seb

    Tuesday, August 24, 2010 11:43 AM

All replies

  • hi there ,

    Please check this Link it have some Information about

    http://www.sisulizer.com/online-help/NetLocalization.shtml

    regards,

    Tuesday, August 24, 2010 1:34 PM
  • Hi S. Edelmeier,

    There may be some resource files for the localization which extension is resx and the file name end up with the language (e.g. Resource1.en-us.resx). When you build the project, it will generate the folder and contain the dll file for of the culture. So you can exclude those items from the project if you do not need them.

    Hope this helps.

    Best regards,
    Kevin Pan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Kevin Pan Wednesday, September 1, 2010 2:02 AM
    • Unmarked as answer by Kevin Pan Thursday, September 2, 2010 8:15 AM
    Friday, August 27, 2010 2:20 PM
  • Hi Kev,

    You are right about the folders and the dlls, but in my entire solution I can't find the resx files. Is there any other place this can be defined than by resx files?

    The only files localized are System.Windows.Interactivity.resources.dll and Microsoft.Expression.Interactions.resources.dll

    Also, the selection of languages is quite weird : de,en,es,it,fr,ja,ko,zh-Hans,zh-Hant (European and asian languages)...

    Thursday, September 2, 2010 7:42 AM
  • Hi S. Edelmeier,

    You can check if the resource files exist in the Properties folder in the project.

    Hope this helps.

    Best regards,
    Kevin Pan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, September 6, 2010 2:31 AM
  • Hi Kevin,

    I checked, they don't exist there. I tried a file search for *.resx (in the whole solution explorer), which didn't find anything either.

    Could this be blend-related? Or is there any other build-setting that causes things like this?

    best wishes

     

    Sebi

    Monday, September 6, 2010 6:37 AM
  • Still haven't found a way to solve this issue. Anyone else out there with an idea?

     

    Thanks in advance

     

    Sebi

    • Proposed as answer by pcdny Thursday, April 28, 2011 8:29 PM
    • Unproposed as answer by pcdny Thursday, April 28, 2011 8:29 PM
    Monday, September 20, 2010 6:50 AM
  • i was having the same issue. I removed following two references and those files/folders no longer show up after build succeeds.

    Microsoft.Expression.Interactions

    System.Windows.Interactivity

    I'm not sure what's the usage of those two refereces. Seems related to expression.

     

    Friday, December 31, 2010 9:39 PM
  • Try this

    remove these folders from

    .\Program Files\Microsoft SDKs\Expression\Blend\.NETFramework\v4.0\Libraries

    clean you project (and remove these same folders) and rebuild

    regards!

    • Proposed as answer by pcdny Thursday, April 28, 2011 8:32 PM
    Thursday, April 28, 2011 8:32 PM
  • Hi,

    I have tried all the mentioned solutions but I am unable to solve this issue.
    Has anybody got the solution for above issue?


    -- Happiness is only real when shared :)
    Friday, January 13, 2012 11:05 AM
  • try copy System.Windows.Interactivity.dll to your project folder, and change the reference System.Windows.Interactivity point to that.
    Tuesday, January 31, 2012 1:38 AM