none
visual studio 2017 settings RRS feed

  • General discussion

  • hi, have visual studio 2017 56.1 installed latest version, when i launch a vs or .sln, it runs in administrator mode and then uac, comes on. using windows 10 64 bit pro, and do not have this when launching any other applications. and also get the devon.exe, and click no. all the time. so what settings do i need to change, don't mind the admindstrator setting in the title bar, as using jaws for windows, just very annoying how to fix it, so it bypasses uac, and got uac on windows set to 66, this is the only application, since i did a reset of windows 10. thanks. any ideas, or workarounds. thanks. and in australia.

    http://startrekcafe.stevesdomain.net http://groups.yahoo.com/groups/JawsOz

    Sunday, February 11, 2018 7:29 AM

All replies

  • Hi Marvin,

    In advance, sorry if I misunderstand your question.
    Please create a shortcut or pin to Taskbar using "devenv.exe".

    # I'm using Visual Studio Pro 2017, and devenv.exe is 
    "C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\devenv.exe".

    Regards,

    Ashidacchi

    Sunday, February 11, 2018 8:00 AM
  • hi, what i mean is there a script or settings, which will instead of launching devon.exe the name of my application, when loading, and have to click no, to save, and also by pass uac, and having administrator mode is no big deal, never had this issue, and have uinstalled, repaired and reinstalled visual studio, and still got these issues. never had these issues before. did try googling for a solution. some one did have a script but only for visual studio 2013 and 2015, which bypassed the uac, and this is the only app on my laptop toshiba satellite pro c-50-a, and all my othe apps open without uace, like office, skype, internet explorer, google chrome, firefox, winamp. very weird. any ideas or suggestions. that's what i want to do, load my sln file, the name of the application comes and load.

    http://startrekcafe.stevesdomain.net http://groups.yahoo.com/groups/JawsOz

    Sunday, February 11, 2018 11:19 PM
  • Hi Marvin,

    I'm not sure if I can understand what you mentioned.
    If you want to make your application to show UAC, please try:
    (1) add "app.manifest": [Project] > [Add New Item] > Application manifest file
    (2) modify "app.manifest":
       in short, activate --  <requestedExecutionLevel level="asInvoker" uiAccess="false" />
    <?xml version="1.0" encoding="utf-8"?>
    <assembly manifestVersion="1.0" xmlns="urn:schemas-microsoft-com:asm.v1">
      <assemblyIdentity version="1.0.0.0" name="MyApplication.app"/>
      <trustInfo xmlns="urn:schemas-microsoft-com:asm.v2">
        <security>
          <requestedPrivileges xmlns="urn:schemas-microsoft-com:asm.v3">
            <!-- UAC マニフェスト オプション
                 Windows のユーザー アカウント制御のレベルを変更するには、
                 requestedExecutionLevel ノードを以下のいずれかで置換します。
    
            <requestedExecutionLevel  level="asInvoker" uiAccess="false" />
            <requestedExecutionLevel  level="requireAdministrator" uiAccess="false" />
            <requestedExecutionLevel  level="highestAvailable" uiAccess="false" />
    
                requestedExecutionLevel 要素を指定すると、ファイルおよびレジストリの仮想化が無効にされます。
                アプリケーションが下位互換性を保つためにこの仮想化を要求する場合、この要素を
                削除します。
            -->
            <requestedExecutionLevel level="asInvoker" uiAccess="false" />
          </requestedPrivileges>
        </security>
      </trustInfo>
    .....
    
    Regards,

    Ashidacchi

    Sunday, February 11, 2018 11:48 PM