The application was unable to start correctly (0xc000007b). Click OK to close the application RRS feed

  • Question

  • Hi All,

    I build ParaView


    from source on a Windows7 Professional 64bit + MSVC2008 + .NET4 + MSVC2008 Redist x64 + MSVC2010 Redist x64. The Release build applications run fine. However, the debug build applications failed to run with error: Missing MSVCP100D.dll. After download MSVCP100D.dll from


    and put it into SysWOW64/ and system32/, I tried to run the debug app.s again. Now the error became what my title says, i.e. 0xc000007b. Could it anything wrong with my environment, e.g. MSVC2008 + .NET4? Shall I just use MSVC2008 Redist x64 and .NET 3.5 along with MSVC2008?

    thanks so much.

    Monday, August 30, 2010 6:18 PM

All replies

  • Hello,

    The error code 0xc000007b means INVALID_IMAGE_FORMAT in ntstatus.h which indicates that some files were corrupted.

    Based on the docmentation here: http://msdn.microsoft.com/en-us/library/8kche8ah.aspx, what you may need is the debug version of MSVCP100.dll. Please try to do static build (using /mt or /mtd option) of your application and see if it persists.

    Since you use VC2008, I recommend you use .NET Framework 3.5 instead of .NET4.0.

    Best regards

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    Tuesday, August 31, 2010 3:06 AM
  • Hi Roahn,

    Thanks for your reply.

    I have tried /MTd and /MT option. However, the problem persists.

    I tried to install .NET 3.5 SP1 from


    And the setup returns

    "You must use "turn Windows features on or off" in the Control Panel to install of configure Microsoft .NET Framework 3.5 SP1."

    In my Windows Features dialog windows, all the subkeys and mainkey of Microsoft .NET Framework 3.5.1 are checked already.

    I have created a brand new x64 console C++ project with only these lines


    #include <iostream>

    void main(int argc, char** argv)


    std::cout << "Hello world." << std::endl;



    The application is compiled with /MDd and /MD flags. It runs absolutely fine.


    My troubled project uses Qt 4.6.3 x64 built from source as shared libraries. The bundled "qtdemo.exe" also has 0xc000007b error whereas other bundled non-graphical applications run fine. Any other idea?

    Thanks so much.





    Wednesday, September 1, 2010 11:57 PM
  • I think that you trying to use 64-bit DLL with 32-bit application (or vice versa).

    Check this.

    Thursday, November 17, 2011 9:14 AM
  • first delete friend in your control panel all the facilities then downloadmicrosoft microsoft redist redist x64 install it and enjoy your dolphinx64
    Wednesday, May 30, 2012 7:24 PM