none
Could not find a base address that matches scheme http for the endpoint with binding BasicHttpBinding. Registered base address schemes are [https]. RRS feed

  • Question

  • Hi,

    I need to use my WCF Web service which is deployed on IIS as https and htpps, but when I try to open service in I browser it throuw error

    Could not find a base address that matches scheme http for the endpoint with binding BasicHttpBinding. Registered base address schemes are [https].

    Please help me if there is something wroung in my web.congig file.

    My web.config is

    Thanks,

    Ajit

    --------------------------------

    <?

    xml version="1.0" encoding="utf-8"

    ?>

    <

    configuration

    >

    <

    system.web

    >

    <

    compilation debug="true"

    />

    </

    system.web

    >

    <

    system.serviceModel

    >

    <

    bindings

    >

    <

    basicHttpBinding

    >

    <

    binding name="basicHttpBindingConfig"

    >

    <

    security mode="Transport"

    >

    </

    security

    >

    </

    binding

    >

    <

    binding name="basicHttpBindingConfig1"

    >

    <

    security mode="None"

    >

    </

    security

    >

    </

    binding

    >

    </

    basicHttpBinding

    >

    <

    wsHttpBinding

    >

    <

    binding name="WSHttpBinding_IMonitorService"

     

    bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"

     

    messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true"

     

    allowCookies="false"

    >

    <

    security mode="Message"

    >

    <

    transport clientCredentialType="Windows" proxyCredentialType="None"

     

    realm=""

    />

    <

    message clientCredentialType="Windows" negotiateServiceCredential="true"

     

    algorithmSuite="Default" establishSecurityContext="true"

    />

    </

    security

    >

    </

    binding

    >

    </

    wsHttpBinding

    >

    </

    bindings

    >

    <

    services

    >

    <

    service behaviorConfiguration="WMWcfWebServiceLib.Service1Behavior"

     

    name="WMWcfWebServiceLib.WMWcfWebService"

    >

    <

    endpoint

     

    address=""

     

    binding="basicHttpBinding"

     

    bindingConfiguration="basicHttpBindingConfig"

     

    contract="WMWcfWebServiceLib.IWMWebService"

    >

    </

    endpoint

    >

    <

    endpoint

     

    address=""

     

    binding="basicHttpBinding"

     

    bindingConfiguration="basicHttpBindingConfig1"

     

    contract="WMWcfWebServiceLib.IWMWebService"

    >

    </

    endpoint

    >

    <

    endpoint

     

    address="mex"

     

    binding="basicHttpBinding"

     

    bindingConfiguration="basicHttpBindingConfig"

     

    contract="IMetadataExchange"

    >

    </

    endpoint

    >

    <

    host

    >

    <

    baseAddresses

    >

    <

    add baseAddress="http://localhost:8731/WMWcfWebServiceLib/WMWcfWebService/"

    />

    </

    baseAddresses

    >

    </

    host

    >

    </

    service

    >

    </

    services

    >

    <

    behaviors

    >

    <

    serviceBehaviors

    >

    <

    behavior name="WMWcfWebServiceLib.Service1Behavior"

    >

    <

    serviceMetadata httpsGetEnabled ="True" httpGetEnabled ="True"

    />

    <

    serviceDebug includeExceptionDetailInFaults="True"

    />

    </

    behavior

    >

    </

    serviceBehaviors

    >

    </

    behaviors

    >

    <

    client

    >

    <

    endpoint address="http://localhost:8254/WitsmlWcfMonitorLib/WcfMonitorService"

     

    binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IMonitorService"

     

    contract="WMWSClient.IMonitorService" name="WSHttpBinding_IMonitorService"

    >

    </

    endpoint

    >

    </

    client

    >

    </

    system.serviceModel

    >

    <

    appSettings

    >

    <

    add key="WitsmlMonitorLogFile" value="WitsmlMonitorWebService.log"

    />

    </

    appSettings

    >

    </

    configuration

    >

    Thursday, May 26, 2011 12:00 PM

Answers

All replies