locked
UAP project not creating RRS feed

  • Question

  • I have installed windows10 10.0.10240.0 & SDK , creating UAP project in VS2015(C#) it show target platform problem open the .csproj file target platform refer the old vesion 

    <TargetPlatformIdentifier>UAP</TargetPlatformIdentifier><TargetPlatformVersion>10.0.0.0</TargetPlatformVersion><TargetPlatformMinVersion>10.0.0.0</TargetPlatformMinVersion>

    Windows 10 is not fresh installed version (windows insider) & VS2015 RTM installed before 29th and today I updated the VS2015 for UAP program

    Please let me know any solution for this 

    Thanks 

    Vinoth.

    Saturday, August 1, 2015 4:19 PM

Answers

  • I solved this issue:

    This error is a bit deceptive. I installed Windows 10 as an upgrade from Win 8.1. And I also upgraded VS from RC to RTM after Windows 10 was released on 7/29. However, when creating UW projects,  I started getting this error:

    Review Solution Actions

    Visual Studio update required

    One or more projects require a platform SDK (UAP, Version: 10.0.10166.0) that is either not

    installed or is included as pat of a future update to Visual Studio.

    Install the platform SDK to open these projects.

     

     

    All the links which say you have to update the TargetPlatformVersion and TargetMinPlatformVersion are only partially correct.   I followed the instructions here (https://msdn.microsoft.com/en-us/library/Mt148501.aspx)  to no avail. I also repaired VS.

    However I noticed that in the link above,  it was asking me to navigate to: : \program files (x86)\windows kits\10\platforms\uap to  figure out what version of platform I had installed. However I noticed that I didn’t have the platform folder in that path.

     

    So, what worked for me was to go to https://dev.windows.com/en-us/downloads/windows-10-sdk and install the standalone sdk. That created the folders in the right place. Now all the udpates I peformed above made sense and the project loaded.

     

    Side note: there’s a stupid bug in VS which has been there for as long as I can tell: whenever you make a change to the project file you have to unload and reload the project twice before you see the changes you made. Seriously Microsoft. Fix these issues.


    • Edited by Kwacks Thursday, August 6, 2015 10:26 PM
    • Proposed as answer by Tina-Shi Friday, August 7, 2015 1:21 AM
    • Marked as answer by VinothRajendran Friday, August 7, 2015 5:07 AM
    Thursday, August 6, 2015 10:25 PM
  • HI,

    1.reset the PC ( settings -> update & security -> reset this pc)

    2. C:\ProgramData\Package Cache (If any folder present , delete all folders)

    3. Install VS 2015 make sure you have selected the UAP project

    4. Install Windows SDK make sure select all options


    Vinoth Rajendran


    Sunday, August 16, 2015 4:49 AM

All replies

  • Hi Vinoth,

    Thank you for posting in MSDN forum.

    First of all, I suggest you could try to right-click your UAP project->Properties->check if you can find the Windows 10(10.0;Build 10240) in Target version tab.

    If you still could not find this Windows 10(10.0;Build 10240) , I suggest you un-install the VS2015 RTM and then install the VS2015 check this issue again.

    Click here to launch VS Enterprise setup

    Note: the above setup file have selected with Win10 Tools by default, so you could install it directly on your machine.

    However, if you can find the Windows 10(10.0;Build 10240), please change it to Windows 10(10.0;Build 10240) and then save it.

    Then you open the .csproj file check this target platform version.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, August 4, 2015 5:58 AM
  • I have the same problem. I have Windows 10 Pro RTM, upgraded from WIndows 8.1 Pro, and I can't open Universal Windows projects. Please see attached screenshot. I have already repaired VS 2015 3 times. I'm following the steps in this tutorial to create the Universal Windows project: https://msdn.microsoft.com/en-us/library/windows/apps/dn609832.aspx

    Tuesday, August 4, 2015 12:57 PM
  • Hi Tina-Shi

    I have a similar issue but mine is a bit more complicated as my project refuse to be creates at all, so all I have is an edit option showing the following in the App1.csproj file:

    <?xml version="1.0" encoding="utf-8"?>
    <Project ToolsVersion="14.0" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
      <Import Project="$(MSBuildExtensionsPath)\$(MSBuildToolsVersion)\Microsoft.Common.props" Condition="Exists('$(MSBuildExtensionsPath)\$(MSBuildToolsVersion)\Microsoft.Common.props')" />
      <PropertyGroup>
        <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
        <Platform Condition=" '$(Platform)' == '' ">x86</Platform>
        <ProjectGuid>{9068c572-5275-4b0b-a79c-5829bdea048e}</ProjectGuid>
        <OutputType>AppContainerExe</OutputType>
        <AppDesignerFolder>Properties</AppDesignerFolder>
        <RootNamespace>App1</RootNamespace>
        <AssemblyName>App1</AssemblyName>
        <DefaultLanguage>en-US</DefaultLanguage>
        <TargetPlatformIdentifier>UAP</TargetPlatformIdentifier>
        <TargetPlatformVersion>10.0.0.0</TargetPlatformVersion>
        <TargetPlatformMinVersion>10.0.0.0</TargetPlatformMinVersion>
        <MinimumVisualStudioVersion>14</MinimumVisualStudioVersion>
        <EnableDotNetNativeCompatibleProfile>true</EnableDotNetNativeCompatibleProfile>
        <FileAlignment>512</FileAlignment>
        <ProjectTypeGuids>{A5A43C5B-DE2A-4C0C-9213-0A381AF9435A};{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}</ProjectTypeGuids>
        
        <PackageCertificateKeyFile>App1_TemporaryKey.pfx</PackageCertificateKeyFile>
        
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Debug|ARM'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\ARM\Debug\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <NoWarn>;2008</NoWarn>
        <DebugType>full</DebugType>
        <PlatformTarget>ARM</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Release|ARM'">
        <OutputPath>bin\ARM\Release\</OutputPath>
        <DefineConstants>TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <Optimize>true</Optimize>
        <NoWarn>;2008</NoWarn>
        <DebugType>pdbonly</DebugType>
        <PlatformTarget>ARM</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
        <UseDotNetNativeToolchain>true</UseDotNetNativeToolchain>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Debug|x64'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\x64\Debug\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <NoWarn>;2008</NoWarn>
        <DebugType>full</DebugType>
        <PlatformTarget>x64</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Release|x64'">
        <OutputPath>bin\x64\Release\</OutputPath>
        <DefineConstants>TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <Optimize>true</Optimize>
        <NoWarn>;2008</NoWarn>
        <DebugType>pdbonly</DebugType>
        <PlatformTarget>x64</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
        <UseDotNetNativeToolchain>true</UseDotNetNativeToolchain>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Debug|x86'">
        <DebugSymbols>true</DebugSymbols>
        <OutputPath>bin\x86\Debug\</OutputPath>
        <DefineConstants>DEBUG;TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <NoWarn>;2008</NoWarn>
        <DebugType>full</DebugType>
        <PlatformTarget>x86</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
      </PropertyGroup>
      <PropertyGroup Condition="'$(Configuration)|$(Platform)' == 'Release|x86'">
        <OutputPath>bin\x86\Release\</OutputPath>
        <DefineConstants>TRACE;NETFX_CORE;WINDOWS_UWP</DefineConstants>
        <Optimize>true</Optimize>
        <NoWarn>;2008</NoWarn>
        <DebugType>pdbonly</DebugType>
        <PlatformTarget>x86</PlatformTarget>
        <UseVSHostingProcess>false</UseVSHostingProcess>
        <ErrorReport>prompt</ErrorReport>
        <Prefer32Bit>true</Prefer32Bit>
        <UseDotNetNativeToolchain>true</UseDotNetNativeToolchain>
      </PropertyGroup>
      <ItemGroup>
        <!-- A reference to the entire .Net Framework and Windows SDK are automatically included -->
        <None Include="project.json" />
      </ItemGroup>
      <ItemGroup>
        <Compile Include="App.xaml.cs">
          <DependentUpon>App.xaml</DependentUpon>
        </Compile>
        <Compile Include="MainPage.xaml.cs">
          <DependentUpon>MainPage.xaml</DependentUpon>
        </Compile>
        <Compile Include="Properties\AssemblyInfo.cs" />
      </ItemGroup>
      <ItemGroup>
        <AppxManifest Include="Package.appxmanifest">
          <SubType>Designer</SubType>
        </AppxManifest>
        
        <None Include="App1_TemporaryKey.pfx" />
        
      </ItemGroup>
      <ItemGroup>
        <Content Include="Properties\Default.rd.xml" />
        <Content Include="Assets\LockScreenLogo.scale-200.png" />
        <Content Include="Assets\SplashScreen.scale-200.png" />
        <Content Include="Assets\Square150x150Logo.scale-200.png" />
        <Content Include="Assets\Square44x44Logo.scale-200.png" />
        <Content Include="Assets\Square44x44Logo.targetsize-24_altform-unplated.png" />
        <Content Include="Assets\StoreLogo.png" />
        <Content Include="Assets\Wide310x150Logo.scale-200.png" />
      </ItemGroup>
      <ItemGroup>
        <ApplicationDefinition Include="App.xaml">
          <Generator>MSBuild:Compile</Generator>
          <SubType>Designer</SubType>
        </ApplicationDefinition>
        <Page Include="MainPage.xaml">
          <Generator>MSBuild:Compile</Generator>
          <SubType>Designer</SubType>
        </Page>
      </ItemGroup>
      
      <PropertyGroup Condition=" '$(VisualStudioVersion)' == '' or '$(VisualStudioVersion)' &lt; '14.0' ">
        <VisualStudioVersion>14.0</VisualStudioVersion>
      </PropertyGroup>
    
      <Import Project="$(MSBuildExtensionsPath)\Microsoft\WindowsXaml\v$(VisualStudioVersion)\Microsoft.Windows.UI.Xaml.CSharp.targets" />
      <!-- To modify your build process, add your task inside one of the targets below and uncomment it. 
           Other similar extension points exist, see Microsoft.Common.targets.
      <Target Name="BeforeBuild">
      </Target>
      <Target Name="AfterBuild">
      </Target>
      -->
    </Project>
    

    And this is from VS Express for Windows 2015

    Tuesday, August 4, 2015 7:19 PM
  • I have tired already to uninstalled and installed VS2015 but no luck .. I hope this problem occur only upgrade the OS

    Vinoth Rajendran

    Tuesday, August 4, 2015 8:40 PM
  • Hi Vinoth,

    @Augusto && @udoyen1

    Thanks for your reply.

    Since you are all get same issue about this

    <TargetPlatformVersion>10.0.0.0</TargetPlatformVersion><TargetPlatformMinVersion>10.0.0.0</TargetPlatformMinVersion>

    I suggest you could try to install same version of VS2015 with Windows 10 SDK on other machine and then check if you still get same issue.

    If you did not get same issue on other machine , I suggest you'd better repair or re-install your OS environment would be better.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, August 5, 2015 6:01 AM
  • Hello,

    Thanks mate.

    I suggest you could try to install same version of VS2015 with Windows 10 SDK on other machine and then check if you still get same issue. - Now is not possbile this steps , cause my os running from windows insider build version .Only solution re-install , I tired to repair also but its not working , repair failed.

    Thanks

    Vinoth.


    Vinoth Rajendran

    Wednesday, August 5, 2015 8:19 AM
  • Hi Tina-Shi,

    Actually I went forward with that solution yesterday. I reset my Windows 10 and everything works perfect now, even other errors not related to Visual Studio were solved.

    Regards.

    Wednesday, August 5, 2015 5:48 PM
  • Hi Vinoth,

    Thanks for your reply.

    I suggest you can refer the Augusto's suggestion to reset or re-install your OS environment and then check this issue.

    If you have any updated message about your issue, please share me.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, August 6, 2015 2:33 AM
  • I solved this issue:

    This error is a bit deceptive. I installed Windows 10 as an upgrade from Win 8.1. And I also upgraded VS from RC to RTM after Windows 10 was released on 7/29. However, when creating UW projects,  I started getting this error:

    Review Solution Actions

    Visual Studio update required

    One or more projects require a platform SDK (UAP, Version: 10.0.10166.0) that is either not

    installed or is included as pat of a future update to Visual Studio.

    Install the platform SDK to open these projects.

     

     

    All the links which say you have to update the TargetPlatformVersion and TargetMinPlatformVersion are only partially correct.   I followed the instructions here (https://msdn.microsoft.com/en-us/library/Mt148501.aspx)  to no avail. I also repaired VS.

    However I noticed that in the link above,  it was asking me to navigate to: : \program files (x86)\windows kits\10\platforms\uap to  figure out what version of platform I had installed. However I noticed that I didn’t have the platform folder in that path.

     

    So, what worked for me was to go to https://dev.windows.com/en-us/downloads/windows-10-sdk and install the standalone sdk. That created the folders in the right place. Now all the udpates I peformed above made sense and the project loaded.

     

    Side note: there’s a stupid bug in VS which has been there for as long as I can tell: whenever you make a change to the project file you have to unload and reload the project twice before you see the changes you made. Seriously Microsoft. Fix these issues.


    • Edited by Kwacks Thursday, August 6, 2015 10:26 PM
    • Proposed as answer by Tina-Shi Friday, August 7, 2015 1:21 AM
    • Marked as answer by VinothRajendran Friday, August 7, 2015 5:07 AM
    Thursday, August 6, 2015 10:25 PM
  • Thanks Kwacks & All

    Vinoth Rajendran

    Friday, August 7, 2015 5:09 AM
  • Hi Augusto,

    I guess this will work but the stress involved in a "reset" was too much for me as I didn't have a CD. I rather had done what Kwacks did. And deleted the faulty projects and re-created them and the Universal Windows App was now working fine. Thank Heavens for this as a reset would have seen apps installed by the pc manufacturer removed.

    Friday, August 7, 2015 8:02 AM
  • I am really stuck/confused by this problem.  I downloaded the standalone SDK, i downloaded it to the default location c:\users\me\downloads... as expected .. i run the setup exe and it still didn't create the folders in the path you outline above.

    Did i need to download/run the sdk installer from a different location?  Also, in the folders the install creates i don't even see the sdk file anywhere.

    Add - reinstall/repair of the sdk does not fix this, and i don't see how re-installing the OS can possibly fix this problem.

    Saturday, August 15, 2015 6:08 PM
  • HI,

    1.reset the PC ( settings -> update & security -> reset this pc)

    2. C:\ProgramData\Package Cache (If any folder present , delete all folders)

    3. Install VS 2015 make sure you have selected the UAP project

    4. Install Windows SDK make sure select all options


    Vinoth Rajendran


    Sunday, August 16, 2015 4:49 AM
  • So... your answer is to effectively reinstall Windows.. wow, if only every problem with M$ development weren't this easy!
    Monday, May 2, 2016 6:47 PM