none
configurations for the release and debug versions RRS feed

  • Question

  • In http://msdn.microsoft.com/en-us/library/ff452649(v=vs.100).aspx, it says that "A Visual Studio project has separate configurations for the release and debug versions of a program. You build the debug version for debugging and the release version for the final release." However, when I change the "configuration" in "Compile", the  the "configuration" in "Debug" changes, vice versa. Is this a bug? Or I missed something?

    I'm using  MS Visual Basic 2010 Express.

    Thank you.

    Friday, February 22, 2013 12:13 AM

Answers

  • Hello,

    When you changed from Debug to Release on the Compile tab under project properties did the tab header show a red circle? If not try using the Browse button (this might sound strange but bear with me), select the Debug folder, accept the look for the red circle, if it appears press CTRL+S, not browse again and select the Release folder, the red circle should appear, press CTRL+S. Close project projecties, build, now open the release folder with Windows Explorer, are the built files there? Yep it is odd but I when encountering this now and then this seems to unconfuse the settings.

    I have seen sometimes when there seems to be confusion within the IDE. If this was a higher version i.e. Ultima I would suggest right clicking in solution explorer solumn name, select configuration manager and change the build there and save.


    kevininstructor

    Friday, February 22, 2013 1:37 AM
    Moderator

All replies

  • Hello,

    When you changed from Debug to Release on the Compile tab under project properties did the tab header show a red circle? If not try using the Browse button (this might sound strange but bear with me), select the Debug folder, accept the look for the red circle, if it appears press CTRL+S, not browse again and select the Release folder, the red circle should appear, press CTRL+S. Close project projecties, build, now open the release folder with Windows Explorer, are the built files there? Yep it is odd but I when encountering this now and then this seems to unconfuse the settings.

    I have seen sometimes when there seems to be confusion within the IDE. If this was a higher version i.e. Ultima I would suggest right clicking in solution explorer solumn name, select configuration manager and change the build there and save.


    kevininstructor

    Friday, February 22, 2013 1:37 AM
    Moderator
  • No, no red circle.

    I tried Browse. The same!

    BTW, I tried to attach screen shot images here and received error!

     
    Friday, February 22, 2013 4:24 PM
  • Since I don't use the Express version not sure if the following would help (also it is in C# yet it may cross over to VB Express)

    http://stackoverflow.com/questions/2812423/how-to-switch-between-debug-and-release-in-visual-c-sharp-2010-express/2938880#2938880


    kevininstructor

    Friday, February 22, 2013 4:41 PM
    Moderator