visual studio 2005 sp1 update fails under XP


  • I've downloaded VS80sp1-KB926601-X86-ENU.exe

    After the extracting finishes, it complains: "The installation source for this product is not available. Verify that the source exists and that you can access it."

    I can run VS2005 v8.0xxx. I've put the CD in the drive but it never really gives me an opportunity to verify anything. When I click OK, the dialog disappears and nothing happens.


    I tried the Check for Update route as well and it won't install that way either but gives a different message.


    Dave Ream

    Monday, April 30, 2007 5:44 PM

All replies

  • You need to run the installer with elevated privileges (as an admin). Installing it from a CD should work fine as the package contents will be extracted to the %temp% folder and run from there.
    Monday, April 30, 2007 8:17 PM
  • It would be wise enough to find out the reason of this failure rather than guessing...

    -Enable Verbose logging by going to registry, HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer and creating a new “string value” as Logging and changing the value “icewarmupv!” This will allow the complete logging of the installation information.

    Try installing the SP again.. and when it will fail.. the log will be captured in %temp% folder with MSI*.log as file name. Search for this log file with the latest timestamp.

    Search for return value 3 in the log and check few lines above that, this will point you the exact reason for failure.




    Tuesday, May 01, 2007 5:05 PM
  • I'm a running with admin privileges.


    I could not find the registry folder you note for Windows Installer.

    I tried creating Logging under ...\software\Microsoft\Installer but didn't get a .log file after re-running the kit.

    Wednesday, May 02, 2007 3:21 PM
  • I did get a log but I'm not sure that the info in it. The pertinent lines seem to be:


    APPCOMPAT: looking for appcompat database entry with ProductCode {...}

      APPCOMPAT: no matching ProductCode found in database.


    SOURCEMGMT: Looking for sourcelist for product {...}

    Note: 1: 1706 2: {...}

    SOURCEMGMT: Failed to resolve source


    This isn't particularly helpful to me however.

    Wednesday, May 02, 2007 3:27 PM
  • I am not sure whether verbose logging is enabled by default with the installation of SP1, I know it is for the installation of Visual Studio. Nevertheless you can enable verbose logging by running the following command:

    • VS80sp1-KB926601-X86-ENU.exe /L* C:\KB926601.log
    Wednesday, May 02, 2007 6:12 PM

    Dave, send me the msi*.log file (You can find it in %temp% folder) at, i will try to figure out the reason for failure. 



    Thursday, May 03, 2007 10:29 AM
  • Please check if you are missing Policies



    Wednesday, May 09, 2007 2:18 PM
  • I'm having the same problem - albeit I installed Public CTP of VSDBPro Service Release 1 (KB936202) .

    Attached is the important part of the log


    MSI (c) (90:80) [10:02:30:937]: Note: 1: 1718 2: C:\DOCUME~1\KOCHL\LOCALS~1\Temp\986f52.msp
    MSI (c) (90:80) [10:02:30:968]: Note: 1: 2729
    File C:\DOCUME~1\KOCHL\LOCALS~1\Temp\986f52.msp was rejected by digital signature policy.
    MSI (c) (90:80) [10:02:31:000]: Couldn't find local patch ''. Looking for it at its source.
    MSI (c) (90:80) [10:02:31:031]: Resolving Patch source.
    MSI (c) (90:80) [10:02:31:046]: User policy value 'SearchOrder' is 'nmu'
    MSI (c) (90:80) [10:02:31:062]: User policy value 'DisableMedia' is 0
    MSI (c) (90:80) [10:02:31:078]: Machine policy value 'AllowLockdownMedia' is 0
    MSI (c) (90:80) [10:02:31:093]: SOURCEMGMT: Media enabled only if package is safe.
    MSI (c) (90:80) [10:02:31:109]: SOURCEMGMT: Looking for sourcelist for product {D93F9C7C-AB57-44C8-BAD6-1494674BCAF7}
    MSI (c) (90:80) [10:02:31:125]: Note: 1: 1706 2: {D93F9C7C-AB57-44C8-BAD6-1494674BCAF7} 3: 
    MSI (c) (90:80) [10:02:31:359]: SOURCEMGMT: Failed to resolve source
    The installation source for this product is not available.  Verify that the source exists and that you can access it.
    MSI (c) (90:80) [10:02:31:390]: Note: 1: 1708
    MSI (c) (90:80) [10:02:31:390]: Note: 1: 2729
    MSI (c) (90:80) [10:02:31:406]: Note: 1: 2729
    MSI (c) (90:80) [10:02:31:406]: Product: Microsoft Visual Studio 2005 Team Explorer - ENU -- Installation failed.

    MSI (c) (90:80) [10:02:31:421]: Attempting to delete file C:\DOCUME~1\KOCHL\LOCALS~1\Temp\986f51.msp
    MSI (c) (90:80) [10:02:31:437]: Attempting to delete file C:\DOCUME~1\KOCHL\LOCALS~1\Temp\986f52.msp
    MSI (c) (90:80) [10:02:32:640]: MainEngineThread is returning 1612
    === Verbose logging stopped: 5/23/2007  10:02:32 ===

    Wednesday, May 23, 2007 3:12 PM
  • Try rebooting the system in safe mode as an adiministrator.

    copy the patch in C drive

    1 Click Start, click Run, type control admintools, and then click OK.

    2 Double-click Local Security Policy.

    3 Click Software Restriction Policies.

      -Right-click Software Restriction Policies, and then click Create New


    4 Under Object Type, double-click Enforcement.

    5 Click All users except local administrators, and then click OK.

    6 Restart the computer in safe mode

    7 Now try installing the patch.


    P.S. After you have installed the patch do remember to revert this settings to default.



    Tuesday, August 14, 2007 4:00 PM

    I fall across the question.

    ----under info---------

    When I install the VS80sp1-kb926601-X86-ENU.exe , Occur the error.

    the error's content is :

            The installation source for this product is not available.Verify that the source exists and that you can access it.


    so, how to deal with that.


    OS: windows xp sp2;

    My PC installs the vs2003 and VS2005.


    Wednesday, August 22, 2007 4:27 AM