System.MissingFieldException: Field not found: 'Microsoft.TeamFoundation.Framework.Common.CatalogResourceTypes.ProjectServerRegistration' RRS feed

  • Question

  • I'm trying to move a Team Project Collection (TPC) from one TFS instance to another.  When I attach the TPC on the new server, I get the following error:

    System.MissingFieldException: Field not found: 'Microsoft.TeamFoundation.Framework.Common.CatalogResourceTypes.ProjectServerRegistration'

    My customer assures me that no one has ever used Project Server but I've still got this error. 

    Anyone have any ideas?  Where would I look the TFS databases to see the Project Server config info?


    [Info   @19:14:32.586] [2011-06-27 19:10:24Z][Informational] Target request context has framework connection string: Data Source=tfssql.baupost.com;Initial Catalog=Tfs_FromVirtualTfs;Integrated Security=True.
    [Info   @19:14:32.586] [2011-06-27 19:10:24Z][Informational] ProjectServer: Retrieving PS nodes from Collection...
    [Error  @19:14:32.586] [2011-06-27 19:10:24Z][Error] Field not found: 'Microsoft.TeamFoundation.Framework.Common.CatalogResourceTypes.ProjectServerRegistration'.
    [Info   @19:14:32.586] [2011-06-27 19:10:24Z][Informational] System.MissingFieldException: Field not found: 'Microsoft.TeamFoundation.Framework.Common.CatalogResourceTypes.ProjectServerRegistration'.
       at Microsoft.TeamFoundation.Server.Servicing.TFCollection.ProjectServerStepPerformer.GetPWACatalogNodes(TeamFoundationRequestContext requestContext, TeamFoundationCatalogService catalogService)
       at Microsoft.TeamFoundation.Server.Servicing.TFCollection.ProjectServerStepPerformer.AttachCatalogEntries(String stepData, ServicingContext servicingContext, Boolean validateOnly)
       at Microsoft.TeamFoundation.Framework.Server.TeamFoundationStepPerformerBase.Microsoft.TeamFoundation.Framework.Server.IStepPerformer.PerformStep(String servicingOperation, String stepType, String stepData, ServicingContext servicingContext)
       at Microsoft.TeamFoundation.Framework.Server.ServicingStepDriver.PerformServicingStep(ServicingStep step, ServicingContext servicingContext, ServicingStepGroup group, ServicingOperation servicingOperation, Boolean validateOnly)
    [Info   @19:14:32.586] [2011-06-27 19:10:24Z] Servicing step Attach the Project Server Catalog Entries failed. (ServicingOperation: AttachCollection; Step group: AttachCollection.TfsProjectServer)
    [Info   @19:14:32.586] [2011-06-27 19:10:24Z][Informational] Clearing dictionary, removing all items.
    [Error  @19:14:32.586] The servicing operation failed.

    Benjamin Day - Microsoft MVP for Visual Studio ALM - http://blog.benday.com
    Monday, June 27, 2011 9:30 PM

All replies

  • The feature pack for TFS and Project Server Integration was installed in both server? Maybe if it was installed only on the new TFS where you try to attach the collection it would expect some fields that are not in the original collection that comes from a TFS without the feature pack. I'm not sure and I should give it a try, but if the feature pack is installed on the destination tfs server, you could try to install on the original one before detatching the collection.



    Ricci Gian Maria. (http://www.codewrecks.com)
    Tuesday, June 28, 2011 8:02 AM
  • Hi Benjamin, can you please confirm that both servers are at the same level, for instance both servers are TFS 2010 RTM or that at the "source" server is TFS 2010 RTM and the "target" server is TFS 2010 SP1. If the "source" server is already TFS 2010 SP1 and you are trying to move the TPC to an RTM server it is not going to work.

    Federico Kolliker Frers - MSFT
    Tuesday, July 26, 2011 7:45 AM
  • Hi Benjamin, I just performed the test of trying to attach a TFS 2010 SP1 collection into a TFS 2010 RTM server and as expected the validation pre-attach failed with error: "TF246091: The team project collection cannot be attached because its version ID is higher than the ID for the configuration database. The collection has the following version: Tfs2010.SP1.KB2182621.P#4. The Team Foundation Server is at the following version: TFS2010.RTM.KB2135068.P#3."

    Now, this is different to what your customer saw so I would be interested about getting more details about the customer server and the TPC itself. Can you please share those?

    Thank you.

    Federico Kolliker Frers - MSFT
    Tuesday, July 26, 2011 7:56 AM
  • I'm experiencing a similar issue.  I'm tyring to move the TFS Collections from one platform to another.  I ran some tests and it all worked fine.  I started running the real deal today and found that someone had installed SP1 on the old application tier which caused an issue when I tried to do an attach on the new application tier.  I installed SP1 so that both were at the same level (Tfs2010.SP1.KB2182621) and tried to attach the TFS collection and got an error (System.MissingFieldException: Field not found: 'Microsoft.TeamFoundation.Framework.Common.CatalogResourceTypes.ProjectServerRegistration) Which caused the attach to fail.  Thinking there might be something different between the test collection and the one I was attaching I tried it with the test collection and got the same error.  We don't have Project Server on either machine and applications installed are identical on both platforms.  Any ideas?
    Wednesday, November 14, 2012 3:41 PM