none
CodeLens does not work on Visual Studio 2019 RRS feed

  • Question

  • Hi 

    I have just installed Visual Studio 2019 v16.0.1 and codelens does not work single project within my solution. All other projects the codelens works fine.

    In Visual Studio 2017 the same project's codeLens works fine no problem.

    Can someone assist me how can i go about troubleshooting this issue with VS 2019?


    Bhavesh

    Thursday, April 18, 2019 8:33 AM

All replies

  • May

    Hi brvaland

    Welcome to the MSDN forum

    Did you modify this project after upgrade to VS2019? Have you re-build it?

    What’s the project type? And could you try to repair VS2019 and check if the “codelens” option is enabled?

    Sorry for that we cannot reproduce it now, if possible, you can upload a demo and some reproduce steps here, we will do our best to diagnose it.

    Sincerely

    May  


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, April 19, 2019 3:53 AM
    Moderator
  • Hi May

    I have not modified this project after installing visual studio 2019 and already tried clean and rebuild. 

    The VS2019 repair did not work and just upgraded today to v16.0.2 but no luck.

    The project is C# Class Library - .Net Framework 4.7.2 and using package.config for packages. 

    NB: If i am to clone repo again to new folder it the codelens works fine for a day and then it does not work after it.

    Let me know if you want me to share any logs or try some thing that help us diagnose the issue.

    Thanks

    Bhavesh


    Bhavesh

    Tuesday, April 23, 2019 8:48 AM
  • Hi brvaland

    Glad to hear your update.

    I cannot repro it on my side, but as you said, I suspect that associated with some third party apps or extension in VS to which be possible block this function.

    Have you installed any extension or some else recently after you update to VS2019? I will share some workarounds to troubleshoot it, you can try it one by one:

    1. Temporarily disable anti-virus
    2. Run VS as safe mode: use command line devenv.exe /safemode that prevents all third-party VS Packages from loading when Visual Studio starts, thus ensuring stable execution. If Codelens is fine, please go to Tools-> Extensions and Updates to uninstall extensions one by one.
    3. Perform a clean boot to check if any third party application is causing the issue, as clean boot helps in eliminating software conflicts. Follow these steps given in the link below to start the computer in clean boot.
    4. Delete Solution user Option file (.suo file) in .vs folder, the .vs folder is a hidden folder at the *.sln folder level.
    5. Re-run VS.

    Also, check out this similar thread to see if it helps: https://stackoverflow.com/a/20828288

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, April 23, 2019 9:27 AM
    Moderator