none
Toolbox not configured in Visual Studio 2017 latest update (15.4) RRS feed

  • Question

  • Hi Team,

    I'm developing a C# based application (.exe). While installing my application, my custom controls will be configured in Visual Studio 2017 toolbox using a .pkgdef file. This scenario was working till the previous update (15.3) of Visual Studio 2017. From the latest update 15.4, my controls were missing in the Visual Studio 2017 toolbox. I haven't changed anything from my end. Also, my toolbox vsix extension is enabled in the latest update 15.4. 

    Can anyone please let me know whether any changes has been done in latest update 15.4. If so, please guide me to configure my controls into latest Visual Studio update 15.4 toolbox using the .pkdef file.

    I have attached the screen shot of my .pkgdef file below.

    

    Thanks,

    Manivannan S.

    Tuesday, October 24, 2017 12:12 PM

All replies

  • Hi Manivannan S,

    Welcome to the MSDN forum.

    >> I'm developing a C# based application (.exe).

    Could you please provide more detail information about how did you create this .exe file?

    >> Also, my toolbox vsix extension is enabled in the latest update 15.4. 

    Do you mean go to Tools>Extensions and updates>Installed, the status of your toolbox vsix extension is enabled? If so, please Uninstall this extension, then directly use the corresponding xxx.vsix file of this toolbox extension to install this extension, then check if this custom toolbox will display in the VS 2017 toolbox or not. This can help us to confirm this issue is caused by the extension or the .exe, thank you for your cooperation.

    >> Can anyone please let me know whether any changes has been done in latest update 15.4.

    Usually, we can check the VS release note like this: Visual Studio 2017 version 15.4 Release Notes to know the detail information about ‘What’s new in this release’.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, October 25, 2017 3:11 AM
    Moderator
  • Hi Sara,

    Thanks for the update.

    >>>Could you please provide more detail information about how did you create this .exe file?

    I'm using C# Console application for creating this .exe file. While running this .exe, vsix file will be installed. While the vsix is being installed, .pkgdef file will be copied to the %localappdata%\Microsoft\VisualStudio\15.0_xxx\Extension location and I'm loading the toolbox from that .pkgdef file.

    >>>This can help us to confirm this issue is caused by the extension or the .exe, thank you for your cooperation.

    I have performed the steps for manually installing the vsix and still the toolbox was not configured in the Visual Studio toolbox. But this was not the case in the previous updates of Visual Studio 2017. I have checked the same manual vsix installation in previous updates and toolbox was configured successfully. 

    And for UWP, I'm using SDK for configuring my controls in UWP toolbox. It was working fine till the previous updates of Visual Studio 2017. 

    If any of my steps for configuring the controls in toolbox were not done properly in the update 15.4 installed machine, I can check and correct it from my side. But all the steps were done perfectly in the update 15.4 installed machine. Everything looks weird after the installation of latest update 15.4. To explain in short, all my previous procedures for configuring my controls in Visual Studio 2017 toolbox were working properly in previous updates and now it was not working in latest update 15.4. 

    Please let me know if anything has to be changed from my end or additional steps has to be done for configuring the controls in Visual Studio 2017 latest update 15.4.

    Thanks,

    Manivannan S. 





    Wednesday, October 25, 2017 1:13 PM
  • Hi Manivannan S,

    According to your description, I create a sample WPF custom control in my Toolbox with VS2017 version 15.4.1. It works fine when I open the Toolbox in a WPF project, the custom control display in Toolbox correctly.

    So I suggest you update your VS2017 to version 15.4.1 first. And then open your custom control project with the latest version of Visual Studio and debug it with Visual Studio Experimental Instance to check whether it could works fine in Experimental Instance.

    In addition, I only find WPF custom Control template in VSIX project Item. How do you create your UWP custom control? Please share a detailed steps to help us reproduce this issue.

    You also could try create a WPF custom control to check whether only the UWP custom control has this issue or all custom controls have this issue.

    Best Regards,
    Weiwei


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, October 26, 2017 7:17 AM
    Moderator