Missing flash.ocx file


  • I am using windows 98 se, and for some reason I am now getting an error message "cannot find flash.ocx file" , can any help? , where do I get a copy, what is it, it keeps going on and on, when the computer is left unattended .

    Its very annoying, any help is greatly appreciated. Using on a home computer.



    Tuesday, January 03, 2006 7:15 PM


All replies

  • looks like your flash player install failed or got corrupted. The simpliest thing to do would be to try and install from


    Tuesday, January 03, 2006 11:30 PM
  • So does this mean I need to re-download macromedia or just a component? If so, where on the page given do I need to click?

    Thanks in advance,
    Sunday, January 15, 2006 2:59 PM
  • actually, looking at that page again, probably the best thing to do is to use the flash uninstaller (, which will remove the flash player from your machine. You can then either use the flash installer, or else simply visit a flash site in your browser and allow your browser to do the detect and install, to end up with a clean version.


    Sunday, January 15, 2006 4:28 PM
  • Okay thank you very much.
    Monday, January 16, 2006 4:51 AM
  • I have tried both of these recommendations, and I thought it had solved it, but after about 8 minutes the same message came back up .

    I don't know what to try next ?


    Regards phil


    Thursday, January 26, 2006 5:07 PM
  • I have the same problem with 98SE.  I have no idea how to help you but I do know that the macromedia flash just hangs up my computer.  If I take it off it works fine.  If I find the answer I'll let you know.
    Thursday, January 26, 2006 5:53 PM
  • Hi, I just got the same problem with W2K, the problem starts when a Screen Saver that I installed from Franklin Covey tries to get in. I have found the file and placed it in every directory I can think of but the screen saver does not work.

    If you want the message to go away just change the screen saver to one of the defaults.


    Saturday, February 11, 2006 5:32 PM
  • Wow!!  Well done Chester.  Switching my screensaver  to one that came with Windows seems to have done the trick!
    Monday, May 15, 2006 10:19 AM
  • i followed some advice i read and it worked !!

    you may have a screensaver that is corrupt or time limited.

    turn it off or delete it.

    Tuesday, August 15, 2006 11:54 AM
  • I'm getting the same missing file message but this just started. Everything was find with my screensaver about a week ago, I've had it for months, and I know nothing is wrong with the file. Only now have I been getting this message, and I don't want to go uninstalling all Flash players on my computer. (I have Flash MX 2004 and don't want to mess with it if I don't have to, it is not my program on this computer and I know it was very expensive.) Is there some way to not mess with the fancy Flash player and get the screensaver to work because I do not like those default screensavers, they make me dizzy.

    • Proposed as answer by Renjithbal Friday, November 27, 2009 7:10 AM
    Wednesday, December 20, 2006 9:54 PM
  • go to you will find  flashplayer you can download or save to your pc i had same trouble this will fix it.
    Saturday, July 21, 2007 10:55 PM
  •  Casey875232332 wrote:
    So does this mean I need to re-download macromedia or just a component? If so, where on the page given do I need to click?

    Thanks in advance,
    Monday, September 10, 2007 7:33 AM