VC++ error while compiling


  • Hi

    When i compile any file in VC++ 2005 express, I get the following error:

    c1xx : fatal error C1083: Cannot open compiler intermediate file: 'C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\_CL_6fd3eb94ex': Permission denied

    I cant figure out what to do here?

    Also, trying to uninstall this beta express edition(to install the release version), it virtually hangs the PC and does not uninstall the VC# and VC++ expresses.  I am using the uninstall tool provided by Microsoft. Please help as all my work is hung due to this problem.

    Friday, November 11, 2005 4:14 PM


All replies

  • Hi:

    I assume the path mentioned in the message above is what your TMP environment variable points to.  Be sure this directory exists, is not read only and that your user account has permission to write there.

    For the Uninstall Issue, see the section titled Manual Uninstall Instructions at:

    Hope This Helps
    Friday, November 11, 2005 5:08 PM
  • If it helps, sometimes I have eliminated this message by just doing a Build ... Clean, then rebuilding the project. (VC++ 6.0)
    Tuesday, May 16, 2006 4:12 PM
  • Make sure you don't use precompiled headers in your projects. (VC6). Or at least not a mix of them. I removed precompiled headers in my project settings for all projects and then it compiled again..
    Saturday, June 16, 2007 5:05 PM
  • I had the same problem after MS Installer ruined my VC2005 Express installation.

    My temp env path was g:\temp\

    VC would attempt to write a temp file to g:\temp\Local Settings\temp\

    This would fail for unknown reasons.

    I then created that exact path manually (by creating the folders in Explorer) and VC compiled everything again.

    If I would then delete the \Temp\ folder under \Local Settings\ it would reproduce the error again. It seems VC is simply unable to create a folder.
    Wednesday, August 15, 2007 12:05 PM
  • This can be a time problem with Virusscanner.

    I have the same problem with Kaspersky AV.

    Wednesday, September 26, 2007 8:56 PM
  • I also got the same problem and it caused because of temp space cleaning.
    So we created again a that folder in temp.So the problem solved.
    Friday, December 14, 2007 6:31 AM