none
cant add reference to visual studio RRS feed

  • Question

  •  Hello im having trouble referencing the microsoft.winodwsmediaservices.dll through visual studio when i try to reference to it doesnt show up under the .net tab in the add reference menu.it shows up in the GAC but neither the 32 or 64 bit will show up in visual studio.i can reference the assembly under \reference assemblies\Microsoft\windows media services\ but i just get a error saying this during runtime.

    "Unable to cast COM object of type 'Microsoft.WindowsMediaServices.Interop.WMSServerClass' to interface type 'Microsoft.WindowsMediaServices.Interop.IWMSServer'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{845FB958-4279-11D2-BF23-00805FBE84A6}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))."

     

     

    using : server 2008 r2 sp1 , windows 7 sdk , visual studio express 2010



    • Edited by ArNy64 Thursday, November 10, 2011 9:51 PM
    Thursday, November 10, 2011 9:47 PM

All replies

  • Hi,

     

    I cannot reproduce your issue with Visual Studio 2010.

    Microsoft.WindowsMediaServices.dll can be added without error in my local machine (win7 32-bit + visual studio 2010).

    Your referenced DLL probably is corrupted. You can try to repair Windows Media Player.

    Otherwise, please run Visual Studio with administrative privilege to avoid other potential issues.

    Here is a link for similar issue http://social.msdn.microsoft.com/Forums/pl-PL/netfx64bit/thread/c8b29202-05c6-44b9-a25d-d3dc3ce8ddf8

     


    Best wishes,


    Robin [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, November 14, 2011 6:23 AM
    Moderator
  • Ok well first off do i need to use server 2008 r2 to develop windows media services. I ask this cause someone else on the windows desktop sdk forum told me i have to use server 2008 but you just said you used win7 32 and before using server 2008 i was using windoes xp pro and tried to develop on that and i would get the same error.Second im developing this on a asp.net website not a desktop app.Ive tried running it as admin but still no luck.The last thing that might be causing it is both server 2008 and windows xp are virtual machines on my local computer.I know i just bombarded you with alot of info lol. but i forgot to put it in my first post.Also ive tried to reference the assembly through VC# and it still wont let me.
    • Edited by ArNy64 Monday, November 14, 2011 7:20 PM
    Monday, November 14, 2011 7:17 PM
  • in my past exp, when you expecting a .net assembly supposed to be show up in the reference list, but it's not.

    for my case, it is because the project i created is WPF app, and the VS default it's "target framework" (project property) as "Client Profile"

    i resolved it by changed to typical .net 4 app (not client profile)

    and the expected assembly shows up in the reference list.

    Tuesday, November 15, 2011 5:43 AM
  • Well i never got this to work i got win 7 too and tried it on there instead of xp but no luck, and had other problems like once you the remove the sdk and try to re install it all you get is a error with the installer.so im just gonna use adobe flash to build my webcam services that seems to be the only one that i could actually uninstall and reinstall without any issuses. thanks for your help though.
    Sunday, November 20, 2011 1:27 AM