none
unable to start visual studio 2012 RRS feed

  • Question

  • Hi all

    Since some days I cannot start visual studio any more.
    Right after start it stops with this exception:
    "Exception has been thrown by the target of an invocation"

    How can I disable addins without having visual Studio open ?
    Using Shft on start does not help.
    I also reinstalled Update 1, also does not help ...

    I am using Visual Studio 2012 Professional on Windows 8 64bit

    Any ideas ?

    Thanks and best regards
    Frank Uray

    Saturday, January 5, 2013 2:01 PM

All replies

  • Try the following steps to resolve the issue, it may help
    1. Open a command prompt.
    2. Navigate to the following folder:
      “%programfiles%\Microsoft Visual Studio 10.0\Common7\IDE\”
    3. Type the following:
    devenv.exe /resetuserdata

    this will reset the user settings of visual studio IDE


    Thanks in Advance Suresh M
    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful"

    Saturday, January 5, 2013 2:39 PM
  •   

    Please post the inner exception to the exception you are getting.

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Saturday, January 5, 2013 2:48 PM
  • Thanks for the idea, but it did not help :-(
    Saturday, January 5, 2013 3:15 PM
  • there is no inner exception, just a messagebox.
    Saturday, January 5, 2013 3:16 PM
  •   

    Are you running the application in debug configuration mode? If not set to Debug configuration and try again.

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Saturday, January 5, 2013 3:19 PM
  • I am not running any application, I just try to start visual Studio.
    Saturday, January 5, 2013 4:00 PM
  • Just now, I completely uninstalled visual Studio and installed it again
    but still the same error ... any other ideas ?

    Saturday, January 5, 2013 4:02 PM
  • Is it possible for you to try and run VS "as administrator"? 

    --
    Mike
    Saturday, January 5, 2013 4:23 PM
  •   

    When uninstalling and reinstalling it does not reset the IDE settings. Try following the steps in this article to reset all settings to there default values.

    How To: Reset Your Settings

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Saturday, January 5, 2013 4:29 PM
  • No, same problem
    Saturday, January 5, 2013 4:39 PM
  • Visual Studio is not running, so I am unable to navigate to the menu.

    Saturday, January 5, 2013 4:40 PM
  •   

    To your statement, "No, same problem", to which post?

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Saturday, January 5, 2013 4:41 PM
  • sorry :-)

    when I run VS as administrator

    Saturday, January 5, 2013 4:43 PM
  • not even "devenv.exe /SafeMode" does work ...
    Saturday, January 5, 2013 4:52 PM
  • Hi Frank;

    You can also reset the IDE settings using the following command from the developers command prompt, just do a search on command in Windows 8 Search charm and you should find it in the list.

    devenv /ResetSettings

      


    Fernando (MCSD)

    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".

    Saturday, January 5, 2013 7:54 PM
  • I tried this already, does also not work.
    Sunday, January 6, 2013 7:24 PM