none
JIT debugger need to be disabled.

    Question

  • Hi,

     

     

     

    I m tired off with same kind of JIT debugger problem. In ASP web application, when ever some error comes, it is just blocking all users to access any application of that server, until we click YES / NO for the popup dialog of the JIT debugger.

     

     

     

    I tried 3 solutions replied in msdn posts regarding JIT debugger mentioned below: 

    1.

     

           It sounds like you want to turn off script debugging on your computer.

     

                1) In Internet Explorer, select Tools -> Options

                2) On the Internet Options dialog, go to the Advanced tab

                3) Make sure that both of these options are checked:

     

                X Disable Script Debugging (Internet Explorer)

                X Disable Script Debugging (Other)

     

    2.

                Right click My PC / Properties.

                Click Advanced Tab

                Under Performance, click Settings

                Click Data Execution Prevention tab

                Select Turn on DEP for essential Windows programs and services only

                Restart Windows

    3.

                Delete the following registry keys:

     

                HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug\Debugger

                HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\DbgManagedDebugger

     

     

    I could nt find any change in result. still having that popup of JIT debugger.

     

    Finally i found an option in Visual Inter Dev 6.0 to disable JIT in Tools --> Options --> Debugger : general, scripts secitons. i had disabled JIT debugger.

     

    Result is now i m not getting that JIT debugger popup , but i m getting other kind of popup which gives a message shown below:

     

    "An unhandled exception ('Transaction context in user by another session') occurred in w3wp.exe [1904].

    Just -In- Time debugging this exception failed with the following error: No installed debugger has Just-In-Time debugging enabled. In Visual Studio Just-In-Time debugging can be enabled from Tools/Options/Debugging/Just-In-Time"

     

    But actually i had disabled this JIT debugger, to get rid of this popup messages which is stoping all other users to access any application of this server.

     

     

    Can Any one help me in this regard.. ASAP.

     

     

     

     

     

     

     

     

     

    Friday, February 29, 2008 6:28 AM

Answers

  •  

    Just in time debugger is a feature that launches when an application has encountered a fatal error. In your case an unhandled exception in w3wp.exe was triggering the JIT debugger. As you have mentioned, you have now successfully disabled the JIT debugger but that doesn't solve the problem, the exception that occurs in your code is still unhandled. You wanted the JIT debugger to be disabled, but i think you should enable the JIT debugger to diagonize the cause for the exception.

     

    Additionally you have metioned the exception string as "'Transaction context in user by another session'"

    See if this helps

    http://support.microsoft.com/?id=279857

     

    Hope this helps

    Karthik

    Friday, February 29, 2008 8:16 AM
    Moderator
  • You could also modify your ASP pages to have an 'On Error Resume Next' or 'On Error Goto <x>'. This should capture exceptions.

     

    Thursday, April 3, 2008 12:32 AM
    Moderator

All replies

  •  

    Just in time debugger is a feature that launches when an application has encountered a fatal error. In your case an unhandled exception in w3wp.exe was triggering the JIT debugger. As you have mentioned, you have now successfully disabled the JIT debugger but that doesn't solve the problem, the exception that occurs in your code is still unhandled. You wanted the JIT debugger to be disabled, but i think you should enable the JIT debugger to diagonize the cause for the exception.

     

    Additionally you have metioned the exception string as "'Transaction context in user by another session'"

    See if this helps

    http://support.microsoft.com/?id=279857

     

    Hope this helps

    Karthik

    Friday, February 29, 2008 8:16 AM
    Moderator
  • Yes i agree  i need to work on that error too. but i m working with this web application since 20 months. Badly , i have never come across this kind of debugger problem ever. So i guess it may be due to change in environment.

     

    As this is a web application, user accessing this application on a client system, cant expect this kind of error, and come to server to reply this popup alert message. More over this is stopping all other user to access any application of that server at that moment until this popup is closed. 

     

    So i would like to do something which doesnot give this debugger popup but simply shows the error on client system, without blocking all other users to access the server applications.

     

     

    Could any one please reply with some exact solution to solve my issue.

     

     

    Awaiting for reply........

     

     

    Friday, February 29, 2008 11:09 AM
  • You could try disabling the dialog by setting the value of

    HKEY_LOCAL_MACHINE\Software\Microsoft\.NETFramework\DbgJITDebugLaunchSetting to 1. No dialog, it simply returns control.

     

    Alternatively you could use global exception handler System.Web.HttpApplication.Error in Global.asax file to handle the exception.

     

    Karthik

     

     

    Friday, February 29, 2008 4:21 PM
    Moderator
  • I could not find DbgJITDebugLaunchSetting at HKEY_LOCAL_MACHINE\Software\Microsoft\.NETFramework\

     

    It is available at HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio

     

    I have changed the value of DbgJITDebugLaunchSetting to 1 (decimal). (Changed radio button selection from Hexa decimal to decimal).

     

    But having same popup message.

     

    As i m working with ASP application I have no global.aspx file.

     

    Im getting this popup message especially when there is an error with data base( OLEDB Errors). Could you please tell me if there is any alternate solution

     

     

    Tuesday, March 4, 2008 6:56 AM
  • Hi,

    you could take a look at the following thread and see if anything works for you:

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=274145&SiteID=1

     

    hope that this helps,

    Alina

     

    Thursday, March 6, 2008 10:10 PM
    Moderator
  • You could also modify your ASP pages to have an 'On Error Resume Next' or 'On Error Goto <x>'. This should capture exceptions.

     

    Thursday, April 3, 2008 12:32 AM
    Moderator
  • I've been getting a JIT error on every start up and after an unknown amount of time.

    Pic

    It says "An exception 'System.NullReferenceException' has occured in SLF5." It pops up everytime I start up or shut down my PC. I'm running XP Pro sp3.

    Any ideas?

    Tuesday, November 25, 2008 10:08 PM