none
openMP4.5 and 5.0 in future - why no/what else?

    General discussion

  • Hey

    Edit, why does my post looks like crap?

    Edit2. <g class="gr_ gr_13 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="13" id="13">Ok</g> what the Fu!?$!" is wrong with this forum ?!

    Since <g class="gr_ gr_28 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="28" id="28">apparently</g> MS  doest not have a "working forum" here is TL<g class="gr_ gr_29 gr-alert gr_gramm gr_inline_cards gr_run_anim Style replaceWithoutSep" data-gr-id="29" id="29">:DR</g>

    Why MS wont update openMp to latest?

    What aternative  can I use to openMp on multi os environment linux/win/macos/etc

    I've been checking <g class="gr_ gr_54 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins replaceWithoutSep" data-gr-id="54" id="54">status</g> of <g class="gr_ gr_29 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="29" id="29">openMP</g> in <g class="gr_ gr_30 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="30" id="30">msvc</g> for a while now. Usually, the same google results keep coming up so I thought it might be time to find out a little more on the subject.

    I'm finding openMP to be a quite awesome tool as I can quickly MP some loops and not have to worry about all the backend work of thread starting/managing/etc. However more and more often answers to my questions require newer openMP than what <g class="gr_ gr_416 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="416" id="416">msvc</g> offers. Now MSVC only offers 2.0 and apparently, it won't offer newer ones. Given how easy/nice the OpenMP lib is, I wonder why does <g class="gr_ gr_665 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="665" id="665">msvc</g> won't support it?

    Also what other libraries could I use that are good/<g class="gr_ gr_800 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="800" id="800">cross platform</g> - <g class="gr_ gr_816 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="816" id="816">linux</g>/win/<g class="gr_ gr_817 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="817" id="817">macos</g>/<g class="gr_ gr_827 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="827" id="827">etc ?</g> - but at the same time, reasonably easy to use/implement?

    Regards

    Dariusz

     








    • Edited by Dariusz89 Friday, November 9, 2018 11:45 PM
    Friday, November 9, 2018 11:40 PM