Certificate Authentication on Windows Store Apps and WCF service RRS feed

  • Question

  • Hi

    I use local WCF service on IIS to serve a windows store apps.   Now I want to put the service accessible from the web.   I want to increase the security.  I want to choose the user who can connect to service.   I set a certificate authentication client on IIS.  This authentication work with all browser that I try (I just have to select the correct certificate).  After that I try in windows store apps using an HttpClient (class) and its work (I must set the HttpClientHandler = ClientCertificateOption.Automatic (indicate that my apps have access to certificate)).  So after that I add service reference, but I’m not able because VS2013 interface give no parameter to set credential.  So I uncheck « Require SSL » on IIS and I add my service reference an it's work.  I check require SSL on IIS and I try the service and I  get the error 403 –Forbidden (the apps try to connect in anonymous).  I such a way to set certificate credential and I’m not able.  With step by step debugger I saw under myservice.ClientCredentials the ClientCertificate.Certificate set to nothing.  These is no way to set this certificate?

    After that I found this page that explain more about security on service for windows store apps.


    It’s seem that Certificate is not there (security authentication) but I saw it’s in debugger.

    Maybe I have to set something on Reference.vb or app.config?

    Thank you

    P.S If this way is not possible (or huge to implement) can you give me the best way to protect my WCF service over the web and easy to call with windows store apps?

    Thursday, October 8, 2015 8:26 PM