none
Request for the permission of type 'System.Security.Permissions.SecurityPermission' RRS feed

  • Question

  • I am using a third party control in my UI. The build is successful without any errors.
    When I run it in debug mode, it throws this exception on that UI control. Now this code is under clearcase view. The view location is local machine only.

    System.Security.SecurityException was unhandled
      Message="Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed."

    But when the whole source tree is copied to someother location in the same machine and then building and running it doesn't give any exception. So how to fix this exception when it is running inside clearcase view.

    thanks,
    Krishna
    Tuesday, July 18, 2006 4:23 AM

Answers

All replies

  • Not sure about this..but this may help you...

    Go to Control Panel / Administrative Tools / Microsoft .NET Framework
    Configuration / configure security settings.
    Then to My Computer->Runtime Security Policy node on the left and clicking
    "Adjust Zone Security" link on the right side , give it full trust

    Tuesday, July 18, 2006 7:27 AM
  • I tried giving fulltrust to the Intranet location, but still got the same error.
    Then found this thread Request for permission to run from Network / Mapped drive

    Ran this command and the problem is solved
    caspol.exe -m -ag LocalIntranet_Zone -url \\<network host>\<share name>\ FullTrust -n FullTrustShare

    Thanks,
    Krishna
    Thursday, July 20, 2006 5:35 AM
  • I tried giving rights but still facing the same issue

    below is the error message

    ---------------------------

    rde.exe - Common Language Runtime Debugging Services

    ---------------------------

    Application has generated an exception that could not be handled.

     

    Process id=0x9c4 (2500), Thread id=0x1098 (4248).

     

    Click OK to terminate the application.

    Click CANCEL to debug the application.

    ---------------------------

    OK   Cancel  

    ---------------------------

    please suggest

    Wednesday, May 26, 2010 11:44 AM
  • Hi,

      I did the below

    Go to Control Panel / Administrative Tools / Microsoft .NET Framework
    Configuration / configure security settings.
    Then to My Computer->Runtime Security Policy node on the left and clicking
    "Adjust Zone Security" link on the right side , give it full trust- give full trust to the Local Intranet also.And the error gine.

    Tuesday, October 26, 2010 11:27 AM