none
RegSvr32 can't register an executable as a service RRS feed

  • Question

  • Hi,

    This is my post build command:

    nmake PvLicManps.mk
    copy PvLicManps.dll $(OutDir)
    regsvr32 /s /c $(OutDir)
    $(TargetPath) -RegServer"

    "

    i run vs2010, the command registers the dll but wont register the executable specified by $(TargetPath) even when replaced

    with the full path (surrounded by quotes), also i run VS as admin,

    Error message:

    VCEnd" exited with code -1073741515.

    Hope you can help :)



    • Edited by Tsvis Tuesday, April 5, 2016 11:45 AM
    Tuesday, April 5, 2016 9:24 AM

Answers

  • Hi Tsvis,

    According to your error message, I think you could first directly run the “<Full path of the EXE file> /RegServer” to register the exe file with replacing the value of “$(TargetPath)” to check whether it could run successfully or not. Here, you’d better make sure the executable file is right without any errors.

    Besides, you could refer to below KB article to troubleshoot the Regsvr32 error messages.

    https://support.microsoft.com/en-us/kb/249873

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 7, 2016 2:07 AM