none
Nuget dependencies are missing after creating a new project with Azure Functions template RRS feed

  • Question

  • I have installed visual studio 2017 (15.6.7) Created a hello world function app using Azure Functions Template , But Azure Functions and Web Jobs Tools dependencies are missing in my project.

    Also, not able to update the package from Microsoft.NET.Sdk.Functions1.0.6 to Microsoft.NET.Sdk.Functions 1.0.13, Getting the following error messages.

    Error :The feed 'nuget.org [https://api.nuget.org/v3/index.json]' lists package 'Microsoft.NET.Sdk.Functions.1.0.6' but multiple attempts to download the nupkg have failed. The feed is either invalid or required packages were removed while the current operation was in progress. Verify the package exists on the feed and try again.
    Unable to find package 'Microsoft.NET.Sdk.Functions.1.0.6'.





    Wednesday, May 2, 2018 5:06 PM

All replies

  • It could be you've cleaned up the temp folder of nugget package under user directory.

    I suggest you go to FunctionApp1.csproj:

    and delete the line(1.0.6) highlighted as above. Then you could go to just install the latest version 1.0.13

     

    Regards,

    Fletcher

     

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, May 3, 2018 6:01 AM
  • I followed the above process, deleted the old package reference and tried to install latest version. still getting the following error.

    Restoring packages for C:\Users\anilkumar.mullapudi\source\repos\FunctionApp2\FunctionApp2\FunctionApp2.csproj...
      GET https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json
      OK https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json 74ms
      GET https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg
      Forbidden https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg 1901ms
    Failed to download package 'Microsoft.NET.Sdk.Functions.1.0.13' from 'https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg'.
    Response status code does not indicate success: 403 (Forbidden).
      GET https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg
      Forbidden https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg 587ms
    Failed to download package 'Microsoft.NET.Sdk.Functions.1.0.13' from 'https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg'.
    Response status code does not indicate success: 403 (Forbidden).
      GET https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg
      Forbidden https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg 555ms
      GET https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json
      OK https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json 86ms
      CACHE https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json
      CACHE https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/index.json
    The feed 'nuget.org [https://api.nuget.org/v3/index.json]' lists package 'Microsoft.NET.Sdk.Functions.1.0.13' but multiple attempts to download the nupkg have failed. The feed is either invalid or required packages were removed while the current operation was in progress. Verify the package exists on the feed and try again.
      Unable to find package 'Microsoft.NET.Sdk.Functions.1.0.13'.
    Time Elapsed: 00:00:03.3776816
    ========== Finished ==========


    


    Thursday, May 3, 2018 5:23 PM
  • After read the error, I think your network just blocked nugget.

    Go for Settings ( Global Settings of your PC ) > Network and Internet > Proxy > Automatic Proxy Setup > and set Automatically detect settings to off

     

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Friday, May 4, 2018 6:13 AM
  • @anilmullapudi

    According to the error messages, "Forbidden https://api.nuget.org/v3-flatcontainer/microsoft.net.sdk.functions/1.0.13/microsoft.net.sdk.functions.1.0.13.nupkg 1901ms", it shows that your network is restricted. 

    What is your network, remote server or local network? You should check if your local network has a policy, if yes, disable it and try it again.

    Besides, please try to access following path in your browse directly:

    https://www.nuget.org/packages/Microsoft.NET.Sdk.Functions/

    If you can access it, you can download the package manually and set it to the global packages folder:

    C:\Users\<UserName>\.nuget\packages

    Then you can change the version the latest version, nuget will restore the latest version.


    MSDN Community Support Please remember to click &quot;Mark as Answer&quot; the responses that resolved your issue, and to click &quot;Unmark as Answer&quot; if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, May 4, 2018 8:29 AM
  • I have verified the Proxy Setup, Automatically detect settings is already turned off. but the still same error exists
    Friday, May 4, 2018 2:24 PM
  • I am not sure whether it is a network issue because i was able to access the package url and able to download.

    and my c:\Users\<UserName>\.nuget\ folder is empty.  I have created the packages folder here and copied the latest microsoft.net.sdk.functions.1.0.13.nupkg file.

    I also updated the .csproj file with the latest Microsoft.NET.Sdk.Functions package.

    <Project Sdk="Microsoft.NET.Sdk">
      <PropertyGroup>
        <TargetFramework>net461</TargetFramework>
      </PropertyGroup>
      <ItemGroup>
        <PackageReference Include="Microsoft.NET.Sdk.Functions" Version="1.0.13" />
      </ItemGroup>
      <ItemGroup>
        <Reference Include="Microsoft.CSharp" />
      </ItemGroup>
      <ItemGroup>
        <None Update="host.json">
          <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
        </None>
        <None Update="local.settings.json">
          <CopyToOutputDirectory>PreserveNewest</CopyToOutputDirectory>
          <CopyToPublishDirectory>Never</CopyToPublishDirectory>
        </None>
      </ItemGroup>
    </Project>
    
    and here is my NuGet.config file
    
    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <packageSources>
        <add key="nuget.org" value="https://api.nuget.org/v3/index.json" />
      </packageSources>nu
      <packageRestore>
        <add key="enabled" value="True" />
        <add key="automatic" value="True" />
      </packageRestore>
      <bindingRedirects>
        <add key="skip" value="False" />
      </bindingRedirects>
      <packageManagement>
        <add key="format" value="0" />
        <add key="disabled" value="False" />
      </packageManagement>
      <disabledPackageSources />
    </configuration>

    I have tried the donet restore from the command prompt, but no luck.

     
    Friday, May 4, 2018 2:43 PM