none
C# My Map-Editor is Sluggish Unless I Run It With A Diagnostics Tool RRS feed

  • Question

  • I'm working with a Map-Editor Tool I've designed to generate the tunnel-maps in an action game.

    The Map-Editor has been working fine up until today.  Suddenly she decides she wants to be sluggish.  Distraught by her insensitivity to my needs, frustrated with my code's wanton lack of respect and just a little irritated by her half-assed attitude I enlisted support from a counselor and ran the Diagnostics Tools available in C#.  Lo and behold, when our relations counselor is looking she kicks into gear.  Pleased by the result I resort back to regular code thinking our little spat was forgotten and we might even have a little cuddle-time later, we start work anew and she's grumpy and slow once more.  I am not a violent man, I love my code ... but this is annoying.

    this video clearly demonstrates the absurdity of my situation.

    https://www.youtube.com/watch?v=fNSUpu7ZR70&feature=youtu.be

    does anyone have any idea?

    Christ


    my code is perfect until i don't find a bug




    Wednesday, October 30, 2019 7:41 PM

Answers

  • Hi Christ Kennedy,

    Thank you for posting here.

    According to your description and video, it seems that there is many caches. Please try to:

    • right-click your project -> Clean -> Build
    • Go to Debug/Options/Symbols, if you set symbols directory, please click "Empty Symbol Cache"
    • clean VS component caches, which are in "C:\Users\[username]\AppData\Local\Microsoft\VisualStudio\16.0_ef41bc86\ComponentModelCache" 

    And also, please go to Debug/Options/General, and try to disable below options:

    • Enable Diagnostic Tools while debugging
    • Enable JavaScript debugging for ASP.NET

    If it persists, please try to run external executable file without visual studio, then check if it is still slow.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Thursday, October 31, 2019 2:39 AM

All replies

  • Hi Christ Kennedy,

    Thank you for posting here.

    According to your description and video, it seems that there is many caches. Please try to:

    • right-click your project -> Clean -> Build
    • Go to Debug/Options/Symbols, if you set symbols directory, please click "Empty Symbol Cache"
    • clean VS component caches, which are in "C:\Users\[username]\AppData\Local\Microsoft\VisualStudio\16.0_ef41bc86\ComponentModelCache" 

    And also, please go to Debug/Options/General, and try to disable below options:

    • Enable Diagnostic Tools while debugging
    • Enable JavaScript debugging for ASP.NET

    If it persists, please try to run external executable file without visual studio, then check if it is still slow.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Thursday, October 31, 2019 2:39 AM
  • thank you for your reply, 

    I'll keep your list of suggestions in mind next time I have a similar issue but I removed moved line of code and it kicked in again.  The change I made was not sufficient to alter the performance but I'll stick to the rational conclusion and say that it did.

    thank you for your help,

    Christ


    my code is perfect until i don't find a bug

    Thursday, October 31, 2019 12:36 PM