.NET Runtime version 2.0.50727.1434 - Fatal Execution Engine Error (79FFEE24) (80131506)


  • Hello,

    I've got a problem with my Windows Vista installation. I can't start programs that use the .Net framework (Visual Studio 2k5,2k8, Event Viewer, etc.). Visual Studio starts, shows the spalsh screen and exits without message.

    It always gives me the following error message in the windows log/even files:
    .NET Runtime version 2.0.50727.1434 - Fatal Execution Engine Error (79FFEE24) (80131506)

    I had a comparable error before I installed SP1, then it was:
    .NET Runtime version 2.0.50727.1433 - Fatal Execution Engine Error (79FFEE24) (80131506)

    I hoped SP1 would solve the problem, but it didn't. The problem came out of the blue, yesterday everything was working fine, today nothing works. I have not installed anything in between those periods.

    I tried to install the hotfix that can be found when searching for "
    80131506", but it wouldn't want to install. I did a "sfc /scannow", but that just said that no files were damaged.

    Hope anyone got any tips how to solve this problem,



    Thursday, February 21, 2008 3:40 PM

All replies

  • I get the same error randomly when building in Visual Studio 2005 and 2008.

    I origionly got this error in Windows XP SP2 and rebuilt my computer to Windows Vista SP1

    The operating system changes made no difference.


    It seems that the more maximum number of parallel project builds I have configured the more often it occurs. However, ultimately this causes visual studio to behave very oddly.


    My solution has roughly 74 C# and C++ projects in it and the parallel builds help tremendously.

    We have seen compile time advantages in setting this number very high 4-8


    My system configuration is this..

    Intel 6750 proc – 2 cores

    Promise Raid 10 array

    4GB ram

    4 Monitors on two Nvidia 7950GT cards.


    Libraryies involved in compile

    Data dynamics - Active Reports

    FarPoint - FarPoint Spread



    While it may seem odd using more than 2 parallel build paths, since there are only two cores in my proc, it is advantageous because a lot of time is spent spooling up and down process during a build.  A process pool would be a great idea for VS.. but anyways.. by utilizing more build paths.. I see higher processor utilization and ultimately the code builds faster.. Sadly this also seems to cause this error more frequently.


    Based my research I think this may involve the FarPoint libraries but this is not conclusive.


    My typical repo for this issue is to set the parallel builds to 32 and rebuild our code base four or more times.


    This will usually cause this exception and then visual studio will have an exception occur.


    Any help would be tremendously helpful.



    Thursday, February 21, 2008 5:28 PM
  • Same problem here. When I try to add to an existing solution a word 2007 addin. visual studio vanishes, and I get this error in the event log. have Vista SP1 x64
    Thursday, March 06, 2008 4:41 AM
  • Once again - same story.

    Sometimes VS2008 Prof crashes without any message and I found the message in the event log.

    After restarting VS I can continue without problem, but I lost the last changes. I'm developing Windows Forms projects in both C# and VB.NET. The crashes occur no matter what language I'm using.

    Friday, March 14, 2008 11:45 AM
  • I get this around 2 or 3 times a day when running VisualStudio2005 on Vista. I just installed Vista SP1 and no difference!
    I'm posting to give you moral support and to tracke the issue ;-)
    Saturday, March 22, 2008 9:01 AM
  • I also have this issue, but it is when I am running any office 2007 application. I have to close every office application before I can then open a new one.


    This is a real pain as I am constantly closing all my office apps, just to open a new document!!


    Thursday, April 17, 2008 4:37 AM
  • I'm having this same error.  I'm not a developer, I'm just running Office 2K7 on Vista Business SP1, both are fully patched as of 10/28/2008.  I noticed this problem after installing Logitech's SetPoint, but it seems unrelated to wether or not SetPoint is running as to wether it rears it's head or not.  I'm also running McAfee 8.5i w/their Anti-Spyware.

    This is a very annoying problem as sometimes I can't get the Office app to open at all.  Also it seems to mostly affect those apps w/the Ribbon, Outlook 2007 has yet to, even on messages (although I do realize that those use the ribbon).

    Any help is greatly appreciated!
    Tuesday, October 28, 2008 4:20 PM